dfs之城堡问题

城堡问题

1 2 3 4 5 6 7 ############################# 1 # | # | # | | # #####---#####---#---#####---# 2 # # | # # # # # #---#####---#####---#####---# 3 # | | # # # # # #---#########---#####---#---# 4 # # | | | | # # ############################# (图 1) # = Wall | = No wall - = No wall


图1是一个城堡的地形图。请你编写一个程序,计算城堡一共有多少房间,最大的房间有多大。城堡被分割成mn(m≤50,n≤50)个方块,每个方块可以有0~4面墙。 
Input程序从标准输入设备读入数据。第一行是两个整数,分别是南北向、东西向的方块数。在接下来的输入行里,每个方块用一个数字(0≤p≤50)描述。用一个数字表示方块周围的墙,1表示西墙,2表示北墙,4表示东墙,8表示南墙。每个方块用代表其周围墙的数字之和表示。城堡的内墙被计算两次,方块(1,1)的南墙同时也是方块(2,1)的北墙。输入的数据保证城堡至少有两个房间。Output城堡的房间数、城堡中最大房间所包括的方块数。结果显示在标准输出设备上。 
Sample Input

4 
7 
11 6 11 6 3 10 6 
7 9 6 13 5 15 5 
1 10 12 7 13 7 5 
13 11 10 8 10 12 13 

Sample Output

5
9

 

#include <iostream>
#include <cstring>


using namespace std;

int R,C;              //行列数 
int rooms[60][60];
int color[60][60];    //方块是否染色过的标记 
int maxRoomArea = 0,roomNum = 0;
int roomArea;

void dfs(int i,int j){
	if(color[i][j]){
		return ;
	}
	++ roomArea;
	color[i][j] = roomNum;
	if((rooms[i][j] & 1) == 0) dfs(i,j-1);		//向西走 
	if((rooms[i][j] & 2) == 0) dfs(i-1,j);		//向北走	
	if((rooms[i][j] & 4) == 0) dfs(i,j+1);		//向东走 
	if((rooms[i][j] & 8) == 0) dfs(i+1,j);		//向南走 
}

int main(int argc, char *argv[]) {
	cin>>R>>C;
	for(int i=0;i<R;i++)		for(int j=0;j<C;j++){
			cin>>rooms[i][j];
		}
	memset(color,0,sizeof(color));
	for(int i=0;i<R;i++)
		for(int j=0;j<C;j++){
			if(!color[i][j]){
				++roomNum;
				roomArea = 0;
				dfs(i,j);
				maxRoomArea = roomArea>maxRoomArea?roomArea:maxRoomArea;
			}
		}
	cout<<roomNum<<endl;
	cout<<maxRoomArea<<endl;
	return 0;
}

  


posted @ 2020-11-03 21:48  Guser  阅读(119)  评论(0编辑  收藏  举报