水题:HDU1303-Doubles

Doubles

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 4740    Accepted Submission(s): 3259


Problem Description
As part of an arithmetic competency program, your students will be given randomly generated lists of from 2 to 15 unique positive integers and asked to determine how many items in each list are twice some other item in the same list. You will need a program to help you with the grading. This program should be able to scan the lists and output the correct answer for each one. For example, given the list 
1 4 3 2 9 7 18 22

your program should answer 3, as 2 is twice 1, 4 is twice 2, and 18 is twice 9. 
 

Input
The input file will consist of one or more lists of numbers. There will be one list of numbers per line. Each list will contain from 2 to 15 unique positive integers. No integer will be larger than 99. Each line will be terminated with the integer 0, which is not considered part of the list. A line with the single number -1 will mark the end of the file. The example input below shows 3 separate lists. Some lists may not contain any doubles.
 

Output
The output will consist of one line per input list, containing a count of the items that are double some other item.
 

Sample Input
1 4 3 2 9 7 18 22 0 2 4 8 10 0 7 5 11 13 1 3 0 -1
 

Sample Output
3 2 0
 

Source
 

Recommend

Eddy   |   We have carefully selected several similar problems for you:  1200 1302 1339 1312 1301 





解题心得:

1、用一个bool标记一下就可以了,主要是要注意一下这个输入的问题。



#include<bits/stdc++.h>
using namespace std;
const int maxn = 1000;
bool num[maxn];//看这个数字是否出现过
int Num[maxn];//记录数字
int main()
{
    while(1)
    {
        int t = 0;
        bool flag = false;
        memset(num,0,sizeof(num));
        while(scanf("%d",&Num[t]) && Num[t])
        {
            if(Num[t] == -1)//出现-1直接标记
            {
                flag = true;
                break;
            }
            num[Num[t]] = true;
            t++;
        }
        if(flag)//出现-1跳出就可以了
            break;
        else
        {
            int cnt = 0;
            for(int i=0;i<t;i++)
                if(num[Num[i]*2])//这个数字乘以二还在里面
                    cnt++;
            printf("%d\n",cnt);
        }
    }
    return 0;
}

posted @ 2017-07-10 21:19  GoldenFingers  阅读(146)  评论(0编辑  收藏  举报