数学基础:HUD1124-Factorial(N!末尾0的个数)

Factorial

Problem Description

The most important part of a GSM network is so called Base Transceiver Station (BTS). These transceivers form the areas called cells (this term gave the name to the cellular phone) and every phone connects to the BTS with the strongest signal (in a little simplified view). Of course, BTSes need some attention and technicians need to check their function periodically.
ACM technicians faced a very interesting problem recently. Given a set of BTSes to visit, they needed to find the shortest path to visit all of the given points and return back to the central company building. Programmers have spent several months studying this problem but with no results. They were unable to find the solution fast enough. After a long time, one of the programmers found this problem in a conference article. Unfortunately, he found that the problem is so called “Travelling Salesman Problem” and it is very hard to solve. If we have N BTSes to be visited, we can visit them in any order, giving us N! possibilities to examine. The function expressing that number is called factorial and can be computed as a product 1.2.3.4….N. The number is very high even for a relatively small N.

The programmers understood they had no chance to solve the problem. But because they have already received the research grant from the government, they needed to continue with their studies and produce at least some results. So they started to study behaviour of the factorial function.

For example, they defined the function Z. For any positive integer N, Z(N) is the number of zeros at the end of the decimal form of number N!. They noticed that this function never decreases. If we have two numbers N1

Input

There is a single positive integer T on the first line of input. It stands for the number of numbers to follow. Then there is T lines, each containing exactly one positive integer number N, 1 <= N <= 1000000000.

Output

For every number N, output a single line containing the single non-negative integer Z(N).

Sample Input

6
3
60
100
1024
23456
8735373

Sample Output

0
14
24
253
5861
2183837


解题心得:


  1. 题意就是叫你算N!的答案末尾有多少个0,很水的题,别人的分析很好我就引用一下就不写分析了。

分析:题目要求解的是N阶乘的结果有多少个0?(1<=N<=1000000000)
注意一下几个方面:
1、任何一个自然数都可分解质因数。N!=1*2*3*(2*2)5(2*3)*…*N=2^a*3^b*5^c*7^d……=(2*5)^c*2^(a-c)*3^b*7^d……=10^c*2^(a-c)*3^b*7^d……

2、两数相乘产生0,是因为2和5相乘。又由于在分解质因数时小的质数的幂次一定>=大的质数的幂次,在N!中2的个数显然大于5的个数,故解决该题转化成找出N!中5的幂次。

3、如何找出5的幂次呢?其实就是 N!中:是5的倍数的数+是5^2的倍数的数+5^3的倍数的数+…..

如50!中:
含有10个5的倍数的数:5,15,20,25,30,35,40,45,50 [50/5=10]
含有2个5^2的倍数的数:25,50 [50/(5^2)=2]
可见N!中一共有12个5相乘,那么N!结果中的0也必有12个。


#include<bits/stdc++.h>
using namespace std;
int main()
{
    long long n;
    int t;
    cin>>t;
    while(t--)
    {
        cin>>n;
        long long sum = 0;
        while(n)
        {
            sum += n / 5;
            n /= 5;
        }
        printf("%lld\n",sum);
    }
    return 0;
}
posted @ 2017-07-30 16:05  GoldenFingers  阅读(158)  评论(0编辑  收藏  举报