POJ:2185-Milking Grid(KMP找矩阵循环节)

Milking Grid

Time Limit: 3000MS
Memory Limit: 65536K

Description

Every morning when they are milked, the Farmer John’s cows form a rectangular grid that is R (1 <= R <= 10,000) rows by C (1 <= C <= 75) columns. As we all know, Farmer John is quite the expert on cow behavior, and is currently writing a book about feeding behavior in cows. He notices that if each cow is labeled with an uppercase letter indicating its breed, the two-dimensional pattern formed by his cows during milking sometimes seems to be made from smaller repeating rectangular patterns.

Help FJ find the rectangular unit of smallest area that can be repetitively tiled to make up the entire milking grid. Note that the dimensions of the small rectangular unit do not necessarily need to divide evenly the dimensions of the entire milking grid, as indicated in the sample input below.

Input

  • Line 1: Two space-separated integers: R and C

  • Lines 2..R+1: The grid that the cows form, with an uppercase letter denoting each cow’s breed. Each of the R input lines has C characters with no space or other intervening character.
    Output

  • Line 1: The area of the smallest unit from which the grid is formed

Sample Input

2 5
ABABA
ABABA

Sample Output

2

Hint

The entire milking grid can be constructed from repetitions of the pattern ‘AB’.


解题心得:

  1. 题意就是给你一个字符矩阵,叫你找出这个字符矩阵的循环节(子矩阵)的大小,给你的字符矩阵可能只是给你一部分。
  2. 刚开始在看到这个题的时候瞬间想到了每一行用KMP找循环节,然后求最小公倍数,然后WA,闷了好久才反应过来为啥只在行里面找,每一列也需要用KMP找寻环节得到列的最小公倍数,然后行列的最小公倍数乘起来才是最小循环矩阵的面积啊。但是要注意如果行或者列的最小公倍数比给出的n,m更大的时候要选择n,m,就是以自身为一个循环节
  3. 注意行列的大小,开数组的时候不要开反了,RE到怀疑人生。

#include<stdio.h>
#include<math.h>
#include<cstring>
#include<algorithm>
#include<iostream>
using namespace std;
typedef long long ll;
const int maxn_length = 1e4+100;
const int maxn_wide = 100;
char maps[maxn_length][maxn_wide];
ll n,m,next[maxn_length];

ll __gcd(ll a,ll b)
{
    if(b == 0)
        return a;
    return __gcd(b,a%b);
}

ll kmp_len(ll pos)//每一行看毛片
{
    ll k = -1;
    memset(next,-1,sizeof(next));
    for(int i=1;i<m;i++)
    {
        while(k > -1 && maps[pos][i] != maps[pos][k+1])
            k = next[k];
        if(maps[pos][i] == maps[pos][k+1])
            k++;
        next[i] = k;
    }
    return m-1-next[m-1];
}

ll get_lcm_length()//得到每一行的最小公倍数
{
    ll ans = 1,cnt;
    for(int i=0;i<n;i++)
    {
        ll len = kmp_len(i);
        cnt = ans/__gcd(len,ans)*len;
        ans = cnt;
        if(ans > m)
            return m;
    }
    return ans;
}

ll kmp_wide(ll pos)//每一列看毛片
{
    ll k = -1;
    memset(next,-1,sizeof(next));
    for(int i=1;i<n;i++)
    {
        while(k > -1 && maps[i][pos] != maps[k+1][pos])
            k = next[k];
        if(maps[i][pos] == maps[k+1][pos])
            k++;
        next[i] = k;
    }
    return n-1-next[n-1];
}

ll get_lcm_wide()//得到每一列的最小公倍数
{
    ll ans = 1,cnt;
    for(int i=0;i<m;i++)
    {
        ll wide = kmp_wide(i);
        cnt = ans/__gcd(ans,wide)*wide;
        ans = cnt;
        if(ans > n)
            return  n;
    }
    return ans;
}

int main()
{
    while(cin>>n>>m)
    {
        for(int i=0;i<n;i++)
            scanf("%s",maps[i]);
        ll lcm_len = get_lcm_length();
        ll lcm_wide = get_lcm_wide();
        lcm_len = min(lcm_len,(ll)m);
        lcm_wide = min(lcm_wide,(ll)n);

        ll ans = lcm_len * lcm_wide;
        printf("%lld\n",ans);
    }
    return 0;
}
posted @ 2018-01-29 19:32  GoldenFingers  阅读(149)  评论(0编辑  收藏  举报