POJ:3258-River Hopscotch

River Hopscotch

Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 17740 Accepted: 7414

Description

Every year the cows hold an event featuring a peculiar version of hopscotch that involves carefully jumping from rock to rock in a river. The excitement takes place on a long, straight river with a rock at the start and another rock at the end, L units away from the start (1 ≤ L ≤ 1,000,000,000). Along the river between the starting and ending rocks, N (0 ≤ N ≤ 50,000) more rocks appear, each at an integral distance Di from the start (0 < Di < L).

To play the game, each cow in turn starts at the starting rock and tries to reach the finish at the ending rock, jumping only from rock to rock. Of course, less agile cows never make it to the final rock, ending up instead in the river.

Farmer John is proud of his cows and watches this event each year. But as time goes by, he tires of watching the timid cows of the other farmers limp across the short distances between rocks placed too closely together. He plans to remove several rocks in order to increase the shortest distance a cow will have to jump to reach the end. He knows he cannot remove the starting and ending rocks, but he calculates that he has enough resources to remove up to M rocks (0 ≤ M ≤ N).

FJ wants to know exactly how much he can increase the shortest distance before he starts removing the rocks. Help Farmer John determine the greatest possible shortest distance a cow has to jump after removing the optimal set of M rocks.

Input

Line 1: Three space-separated integers: L, N, and M
Lines 2..N+1: Each line contains a single integer indicating how far some rock is away from the starting rock. No two rocks share the same position.

Output

Line 1: A single integer that is the maximum of the shortest distance a cow has to jump after removing M rocks

Sample Input

25 5 2
2
14
11
21
17

Sample Output

4

Hint

Before removing any rocks, the shortest jump was a jump of 2 from 0 (the start) to 2. After removing the rocks at 2 and 14, the shortest required jump is a jump of 4 (from 17 to 21 or from 21 to 25).


解题心得:

  1. 有n块石头排成一列,每个石头距离原点有一个距离,现在要移走m块石头,问这些牛要跳在(n-m) 块石头上,怎么移走石头让牛每次跳的最短距离最大。输入最短的最大距离。
  2. 看到这个最短距离最大其实也就想到二分了。首先要明白(n-m)块石头,牛要跳n-m+2次(起点和终点没有石头但是也要跳)。然后二分检查。

#include <algorithm>
#include <stdio.h>
#include <cstring>
using namespace std;
const int maxn = 5e5+100;
int pos[maxn],n,m,l,tot;

void init() {
    pos[0] = 0;
    for(int i=1;i<=n;i++)
        scanf("%d",&pos[i]);
    pos[n+1] = l;
    n += 2;
    sort(pos,pos+n);
    tot = n-m;
}

bool checke(int len){
    int cnt = 1,now = pos[0];
    for(int i=1;i<n;i++) {
        if(pos[i] - now >= len) {
            cnt++;
            now = pos[i];
        }
    }
    if(cnt >= tot)
        return true;
    return false;
}

int binary_search() {
    int l = 0,r = 1e9+100;
    while(r - l > 1) {
        int mid = (l + r) / 2;
        if(checke(mid))
            l = mid;
        else
            r = mid;
    }
    return l;
}

int main() {
    while(scanf("%d%d%d",&l,&n,&m) != EOF) {
        init();
        int ans = binary_search();
        printf("%d\n",ans);
    }
    return 0;
}
posted @ 2018-04-07 09:58  GoldenFingers  阅读(104)  评论(0编辑  收藏  举报