数据结构实验之链表七:单链表中重复元素的删除
Description
按照数据输入的相反顺序(逆位序)建立一个单链表,并将单链表中重复的元素删除(值相同的元素只保留最后输入的一个)。
Output
第一行输出初始链表元素个数;
第二行输出按照逆位序所建立的初始链表;
第三行输出删除重复元素后的单链表元素个数;
第四行输出删除重复元素后的单链表。
Sample Input
10
21 30 14 55 32 63 11 30 55 30
Sample Output
10
30 55 30 11 63 32 55 14 30 21
7
30 55 11 63 32 14 21
#include<stdio.h>
#include<stdlib.h>
struct node{
int data;
struct node *next;
};
struct node *creat(int n){
struct node *head, *tail, *p;
head = (struct node *)malloc(sizeof(struct node));
head->next = NULL;
tail = head;
for(int i=0; i<n; i++){
p = (struct node *)malloc(sizeof(struct node));
scanf("%d", &p->data);
p->next = head->next;
head->next = p;
}
return head;
};
struct node *del(struct node *head, int n){
struct node *q, *s, *t;
q = head->next;
while(q != NULL){
s = q;
while(s->next != NULL){
if(s->next->data == q->data){
t = s->next;
s->next = t->next;
free(t);
n--;
}
else s = s->next;
}
q = q->next;
}
printf("%d\n", n);
return head;
};
int main(){
int n;
scanf("%d", &n);
struct node *q, *head, *t;
q = head = creat(n);
printf("%d\n", n);
while(q->next != NULL){
q->next->next == NULL? printf("%d", q->next->data): printf("%d ", q->next->data);
q = q->next;
}
printf("\n");
t = del(head, n);
while(t->next != NULL){
t->next->next == NULL? printf("%d", t->next->data): printf("%d ", t->next->data);
t = t->next;
}
printf("\n");
return 0;
}