数据结构实验之链表一:顺序建立链表

Description

输入N个整数,按照输入的顺序建立单链表存储,并遍历所建立的单链表,输出这些数据。

Input

第一行输入整数的个数N; 
第二行依次输入每个整数。

Output

输出这组整数。

Sample Input

8
12 56 4 6 55 15 33 62

Sample Output

12 56 4 6 55 15 33 62

Hint

不得使用数组!

#include<stdio.h>
#include<stdlib.h>
struct node{
    int data;
    struct node* next;
};
struct node* creat(int n){
    struct node *head, *tail, *p;
    head = (struct node*)malloc(sizeof(struct node));
    head->next = NULL;
    tail = head;
    for(int i=0; i<n; i++)
    {
        p = (struct node*)malloc(sizeof(struct node));
        scanf("%d", &p->data);
        p->next = NULL;
        tail->next = p;
        tail = p;
    }
    return head;
};
int main(){
    int n;
    scanf("%d", &n);
    struct node *q, *head;
    head = creat(n);
    q = head;
    while(q->next != NULL){
        q->next->next==NULL? printf("%d",q->next->data): printf("%d ", q->next->data);
        q = q->next;
    }
    printf("\n");
    return 0;
}