Eqs

Description

Consider equations having the following form: 
a1x13+ a2x23+ a3x33+ a4x43+ a5x53=0 
The coefficients are given integers from the interval [-50,50]. 
It is consider a solution a system (x1, x2, x3, x4, x5) that verifies the equation, xi∈[-50,50], xi != 0, any i∈{1,2,3,4,5}. 

Determine how many solutions satisfy the given equation. 

Input

The only line of input contains the 5 coefficients a1, a2, a3, a4, a5, separated by blanks.

Output

The output will contain on the first line the number of the solutions for the given equation.

Sample Input

37 29 41 43 47

Sample Output

654

Source

#include<stdio.h>
#include<string.h>
short a[12500001], b[12500001];
int main()
{
    int a1, a2, a3, a4, a5, ans=0, i, j;
    scanf("%d%d%d%d%d", &a1, &a2, &a3, &a4, &a5);
    memset(a, 0, sizeof(a));
    memset(b, 0, sizeof(b));
    for(i=-50; i<=50; i++)
        for(j=-50; j<=50; j++)
        {
            if(i==0 || j==0)
                continue;
            int sum = a1*i*i*i + a2*j*j*j;
            if(sum <= 0)
                a[-sum]++;
            else
                b[sum]++;
        }
    for(i=-50; i<=50; i++)
        for(j=-50; j<=50; j++)
            for(int k=-50; k<=50; k++)
            {
                if(i==0 || j==0 || k==0)
                    continue;
                int sum = a3*i*i*i + a4*j*j*j + a5*k*k*k;
                if(-12500000<=sum && sum<=12500000)
                {
                    if(sum < 0)
                    {
                        if(b[-sum] != 0)
                            ans += b[-sum];
                    }
                    else
                    {
                        if(a[sum] != 0)
                            ans += a[sum];
                    }
                }
            }
    printf("%d\n", ans);
    return 0;
}