I am a slow walker,but I never walk backwards. Abraham Lincoln

GeekZRF

POJ 3107.Godfather 树形dp

Godfather
Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 7536   Accepted: 2659

Description

Last years Chicago was full of gangster fights and strange murders. The chief of the police got really tired of all these crimes, and decided to arrest the mafia leaders.

Unfortunately, the structure of Chicago mafia is rather complicated. There are n persons known to be related to mafia. The police have traced their activity for some time, and know that some of them are communicating with each other. Based on the data collected, the chief of the police suggests that the mafia hierarchy can be represented as a tree. The head of the mafia, Godfather, is the root of the tree, and if some person is represented by a node in the tree, its direct subordinates are represented by the children of that node. For the purpose of conspiracy the gangsters only communicate with their direct subordinates and their direct master.

Unfortunately, though the police know gangsters’ communications, they do not know who is a master in any pair of communicating persons. Thus they only have an undirected tree of communications, and do not know who Godfather is.

Based on the idea that Godfather wants to have the most possible control over mafia, the chief of the police has made a suggestion that Godfather is such a person that after deleting it from the communications tree the size of the largest remaining connected component is as small as possible. Help the police to find all potential Godfathers and they will arrest them.

Input

The first line of the input file contains n — the number of persons suspected to belong to mafia (2 ≤ n ≤ 50 000). Let them be numbered from 1 to n.

The following n − 1 lines contain two integer numbers each. The pair aibi means that the gangster ai has communicated with the gangster bi. It is guaranteed that the gangsters’ communications form a tree.

Output

Print the numbers of all persons that are suspected to be Godfather. The numbers must be printed in the increasing order, separated by spaces.

Sample Input

6
1 2
2 3
2 5
3 4
3 6

Sample Output

2 3

Source

Northeastern Europe 2005, Northern Subregion
 
题意:输出一棵树的所有重心
思路:树形dp。STL超时,用前向星存图。
代码:
复制代码
#include<iostream>
#include<cstdio>
#include<cmath>
#include<cstring>
#include<queue>
#include<stack>
#include<map>
#include<vector>
#include<set>
#include<bitset>
using namespace std;
#define PI acos(-1.0)
#define eps 1e-8
typedef long long ll;
typedef pair<int,int> P;
const int N=1e5+100,M=1e5+100;
const int inf=0x3f3f3f3f;
const ll INF=1e18+7,mod=1e9+7;
int n;
vector<int>G[N];
int ans;
int si[N],maxx[N];
struct edge
{
    int from,to;
    int next;
};
edge es[M];
int cnt,head[N];
void init()
{
    cnt=0;
    memset(head,-1,sizeof(head));
}
void addedge(int u,int v)
{
    cnt++;
    es[cnt].from=u,es[cnt].to=v;
    es[cnt].next=head[u];
    head[u]=cnt;
}
int dfs(int u,int fa)
{
    for(int i=head[u]; i!=-1; i=es[i].next)
    {
        int v=es[i].to;
        if(v==fa) continue;
        si[u]+=dfs(v,u);
        maxx[u]=max(maxx[u],si[v]);
    }
    si[u]++;
    maxx[u]=max(maxx[u],n-si[u]);
    ans=min(ans,maxx[u]);
    return si[u];
}
int main()
{
    while(scanf("%d",&n)!=EOF)
    {
        init();
        for(int i=1; i<n; i++)
        {
            int u,v;
            scanf("%d%d",&u,&v);
            addedge(u,v);
            addedge(v,u);
        }
        memset(si,0,sizeof(si));
        memset(maxx,0,sizeof(maxx));
        ans=inf;
        dfs(1,0);
        int cou=0;
        for(int i=1; i<=n; i++)
        {
            if(maxx[i]==ans&&!cou) printf("%d",i),cou++;
            else if(maxx[i]==ans) printf(" %d",i),cou++;
        }
        printf("\n");
        for(int i=0; i<=n+10; i++) G[i].clear();
    }
    return 0;
}
前向星存图 树形dp
复制代码

 

posted on   GeekZRF  阅读(142)  评论(0编辑  收藏  举报

编辑推荐:
· 深入理解 Mybatis 分库分表执行原理
· 如何打造一个高并发系统?
· .NET Core GC压缩(compact_phase)底层原理浅谈
· 现代计算机视觉入门之:什么是图片特征编码
· .NET 9 new features-C#13新的锁类型和语义
阅读排行:
· 手把手教你在本地部署DeepSeek R1,搭建web-ui ,建议收藏!
· Spring AI + Ollama 实现 deepseek-r1 的API服务和调用
· 《HelloGitHub》第 106 期
· 数据库服务器 SQL Server 版本升级公告
· C#/.NET/.NET Core技术前沿周刊 | 第 23 期(2025年1.20-1.26)

导航

统计

点击右上角即可分享
微信分享提示