I am a slow walker,but I never walk backwards. Abraham Lincoln

GeekZRF

POJ 3061.Subsequence 尺取法

Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 14910   Accepted: 6301

Description

A sequence of N positive integers (10 < N < 100 000), each of them less than or equal 10000, and a positive integer S (S < 100 000 000) are given. Write a program to find the minimal length of the subsequence of consecutive elements of the sequence, the sum of which is greater than or equal to S.

Input

The first line is the number of test cases. For each test case the program has to read the numbers N and S, separated by an interval, from the first line. The numbers of the sequence are given in the second line of the test case, separated by intervals. The input will finish with the end of file.

Output

For each the case the program has to print the result on separate line of the output file.if no answer, print 0.

Sample Input

2
10 15
5 1 3 5 10 7 4 9 2 8
5 11
1 2 3 4 5

Sample Output

2
3
题目链接:http://poj.org/problem?id=3061
题意:n个正整数,求最少的连续个数的和大于等于s。
思路:前缀和是递增的,所以可以先固定l,然后二分符合的右界。
尺取法:通常是指对数组保存一对下标(起点,终点),然后,根据实际情况推进这两个端点直至得到答案。
首先固定l,然后r一直往后推进直至和大于等于s,
然后l往后推进,直至和小于s,再次将r往后推进。。。直至结束。
代码:
#include<iostream>
#include<cstdio>
#include<cmath>
#include<cstring>
#include<algorithm>
#include<map>
#include<queue>
#include<stack>
#include<vector>
#include<set>
using namespace std;
#define PI acos(-1.0)
typedef long long ll;
typedef pair<int,int> P;
const int maxn=1e5+110,maxm=1e5+100,inf=0x3f3f3f3f,mod=1e9+7;
const ll INF=1e13+7;
int a[maxn];
int main()
{
    int T;
    scanf("%d",&T);
    while(T--)
    {
        int n,s;
        scanf("%d%d",&n,&s);
        int l=0,cou=0;
        int ans=inf;
        for(int i=1; i<=n; i++)
        {
            scanf("%d",&a[i]);
            cou+=a[i];
            while(cou>=s)
            {
                ans=min(ans,i-l);
                cou-=a[++l];
                if(l==i) break;
            }
        }
        if(ans==inf) cout<<0<<endl;
        else cout<<ans<<endl;
    }
    return 0;
}
尺取法

 


posted on 2017-07-04 21:08  GeekZRF  阅读(138)  评论(0编辑  收藏  举报

导航