HDU 1596 find the safest road

find the safest road

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others) Total Submission(s): 5279    Accepted Submission(s): 1898

Problem Description
XX星球有很多城市,每个城市之间有一条或多条飞行通道,但是并不是所有的路都是很安全的,每一条路有一个安全系数s,s是在 0 和 1 间的实数(包括0,1),一条从u 到 v 的通道P 的安全度为Safe(P) = s(e1)*s(e2)…*s(ek) e1,e2,ek是P 上的边 ,现在8600 想出去旅游,面对这这么多的路,他想找一条最安全的路。但是8600 的数学不好,想请你帮忙 ^_^
 
Input
输入包括多个测试实例,每个实例包括: 第一行:n。n表示城市的个数n<=1000; 接着是一个n*n的矩阵表示两个城市之间的安全系数,(0可以理解为那两个城市之间没有直接的通道) 接着是Q个8600要旅游的路线,每行有两个数字,表示8600所在的城市和要去的城市
 
Output
如果86无法达到他的目的地,输出"What a pity!", 其他的输出这两个城市之间的最安全道路的安全系数,保留三位小数。
 
Sample Input
3
1 0.5 0.5
0.5 1 0.4
0.5 0.4 1
3
1 2
2 3
1 3
 
Sample Output
0.500
0.400
0.500
 
Author
ailyanlu
 
Source
 
Recommend
8600   |   We have carefully selected several similar problems for you:  1217 1598 1142 1690 1874 
 
思路:Dijkstra或者Floyd
 
AC代码:
#include <iostream>
#include <cstring>
#include <cstdio>
#include <cstdlib>
#include <algorithm>
#include <cmath>
using namespace std;
const int MAXN = 0;
double map[1010][1010];
int n;
int q;
double value;
int a,b;
void Floyd()
{
    for(int k = 1;k <= n;k ++)
    {
        for(int i = 1;i <= n;i ++)
        {
            for(int j = 1;j <= n;j ++)
            {
                if(map[i][k] * map[k][j] > map[i][j])
                   {
                       map[i][j] = map[i][k] * map[k][j];
                   }
            }
        }
    }
}
int main()
{
    while(~scanf("%d",&n))
    {
        for(int i = 1;i <= n;i ++)
            for(int j = 1;j <= n;j ++)
            {
                scanf("%lf",&map[i][j]);
            }
        Floyd();
        scanf("%d",&q);
        while(q --)
        {
            scanf("%d%d",&a,&b);
            if(map[a][b] == MAXN)
                printf("What a pity!\n");
            else
                printf("%.3lf\n",map[a][b]);
        }
    }
    return 0;
}

 

超时代码:

#include <iostream>
#include <cstring>
#include <cstdio>
#include <cstdlib>
#include <algorithm>
#include <cmath>
using namespace std;
const int MAXN = 0;
double map[1010][1010];
int n;
int q;
double value;
int a,b;
void Floyd()
{
    for(int k = 1;k <= n;k ++)
    {
        for(int i = 1;i <= n;i ++)
        {
            for(int j = 1;j <= n;j ++)
            {
                if(map[i][k] != MAXN && map[k][j] != MAXN && map[i][j] != MAXN
                   && map[i][k] * map[k][j] > map[i][j])
                   {
                       map[i][j] = map[i][k] * map[k][j];
                   }
            }
        }
    }
}
int main()
{
    while(~scanf("%d",&n))
    {
        for(int i = 1;i <= n;i ++)
            for(int j = 1;j <= n;j ++)
            {
                scanf("%lf",&map[i][j]);
            }
        Floyd();
        scanf("%d",&q);
        while(q --)
        {
            scanf("%d%d",&a,&b);
            if(map[a][b] == MAXN)
                printf("What a pity!\n");
            else
                printf("%.3lf\n",map[a][b]);
        }
    }
    return 0;
}

 为什么这个会超时  if(map[i][k] != MAXN && map[k][j] != MAXN && map[i][j] != MAXN
                           
&& map[i][k] * map[k][j] > map[i][j])
而  if(map[i][k] * map[k][j] > map[i][j]) 会AC,这不科学啊,上面的循环次数一定会等于或者
小于下面的循环次数

posted on 2013-11-05 20:19  天使是一个善良的神  阅读(174)  评论(0编辑  收藏  举报

导航