HDU 1875 畅通工程再续

畅通工程再续

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others) Total Submission(s): 11441    Accepted Submission(s): 3481

Problem Description
相信大家都听说一个“百岛湖”的地方吧,百岛湖的居民生活在不同的小岛中,当他们想去其他的小岛时都要通过划小船来实现。现在政府决定大力发展百岛湖,发展首先要解决的问题当然是交通问题,政府决定实现百岛湖的全畅通!经过考察小组RPRush对百岛湖的情况充分了解后,决定在符合条件的小岛间建上桥,所谓符合条件,就是2个小岛之间的距离不能小于10米,也不能大于1000米。当然,为了节省资金,只要求实现任意2个小岛之间有路通即可。其中桥的价格为 100元/米。
 
Input
输入包括多组数据。输入首先包括一个整数T(T <= 200),代表有T组数据。 每组数据首先是一个整数C(C <= 100),代表小岛的个数,接下来是C组坐标,代表每个小岛的坐标,这些坐标都是 0 <= x, y <= 1000的整数。
 
Output
每组输入数据输出一行,代表建桥的最小花费,结果保留一位小数。如果无法实现工程以达到全部畅通,输出”oh!”.
 
Sample Input
2
2
10 10
20 20
3
1 1
2 2
1000 1000
 
Sample Output
1414.2
oh!
 
Author
8600
 
Source
 
Recommend
lcy   |   We have carefully selected several similar problems for you:  1874 1272 1301 1856 1325 
 
思路:Kruskal
 
代码:
#include <iostream>
#include <cstring>
#include <cstdio>
#include <cstdlib>
#include <cmath>
#include <algorithm>
using namespace std;
int t;
int the_last_flag;
double the_last_sum;
int n,m;
int map[110];
int posi[110][2];
struct Node
{
    int first,end;
    bool select;
    double value;
}Edge[10010];
int find(int x)
{
    while(x != map[x])
       x = map[x];
    return x;
}
void Merge(int x,int y)
{
    int p = find(x);
    int q = find(y);
    if(p < q)
      map[q] = p;
    else
      map[p] = q;
}
double position(int x1,int y1,int x2,int y2)
{
    return sqrt(pow(x1 - x2,2) + pow(y1 - y2,2));
}
int cmp(Node a,Node b)
{
    if(a.value != b.value)
       return a.value < b.value;
    if(a.first != b.first)
       return a.first < b.first;
    return a.end < b.end;
}
void Kruskal(Node *Edge,int n,int m)
{
    the_last_flag = 0;
    sort(Edge + 1,Edge + m + 1,cmp);
    for(int i = 1;i <= m;i ++)
    {
        if(the_last_flag == n - 1)
           break ;
        int x = find(Edge[i].first);
        int y = find(Edge[i].end);
        if(x != y)
        {
            Edge[i].select = true;
            Merge(x,y);
            the_last_flag ++;
        }
    }
}
int main()
{
    scanf("%d",&t);
    while(t --)
    {
        scanf("%d",&n);
        memset(posi,0,sizeof(posi));
        for(int i = 1;i <= n;i ++)
           map[i] = i;
        for(int i = 1;i <= n;i ++)
           scanf("%d%d",&posi[i][0],&posi[i][1]);
        int pos = 0;
        for(int i = 1;i <= n;i ++)
           for(int j = i + 1;j <= n;j ++)
           {
               if(10 - position(posi[i][0],posi[i][1],posi[j][0],posi[j][1]) > 0.0001 ||
                  position(posi[i][0],posi[i][1],posi[j][0],posi[j][1]) - 1000 > 0.0001)
                     continue ;
               Edge[++ pos].first = i;
               Edge[pos].end = j;
               Edge[pos].select = false;
               Edge[pos].value = position(posi[i][0],posi[i][1],posi[j][0],posi[j][1]);
           }
        Kruskal(Edge,n,pos);
        if(the_last_flag != n - 1)
             printf("oh!\n");
        else
        {
            the_last_sum = 0;
            for(int i = 1;i <= pos;i ++)
               if(Edge[i].select == true)
                   the_last_sum += Edge[i].value;
            printf("%.1lf\n",100 * the_last_sum);
        }
    }
    return 0;
}

 

posted on 2013-10-22 19:16  天使是一个善良的神  阅读(177)  评论(0编辑  收藏  举报

导航