HDU 1196 Lowest Bit

Lowest Bit

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 6591    Accepted Submission(s): 4836

Problem Description
Given an positive integer A (1 <= A <= 100), output the lowest bit of A.
For example, given A = 26, we can write A in binary form as 11010, so the lowest bit of A is 10, so the output should be 2.
Another example goes like this: given A = 88, we can write A in binary form as 1011000, so the lowest bit of A is 1000, so the output should be 8.
 
Input
Each line of input contains only an integer A (1 <= A <= 100). A line containing "0" indicates the end of input, and this line is not a part of the input data.
 
Output
For each A in the input, output a line containing only its lowest bit.
 
Sample Input
26
88
0
 
Sample Output
2
8
 
Author
SHI, Xiaohan
 
Source
 
Recommend
Ignatius.L
 
思路:位运算
 
代码:
#include <iostream>
#include <algorithm>
#include <cstring>
#include <cstdlib>
#include <cstdio>
using namespace std;
int n;
int lowbit(int x)
{
    return x & (- x);
}
int main()
{
    while(scanf("%d",&n),n != 0)
    {
        printf("%d\n",lowbit(n));
    }
    return 0;
}

 

posted on 2013-10-17 00:03  天使是一个善良的神  阅读(171)  评论(0编辑  收藏  举报

导航