HDU 2602 Bone Collector

Bone Collector

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 22357    Accepted Submission(s): 9071


Problem Description
Many years ago , in Teddy’s hometown there was a man who was called “Bone Collector”. This man like to collect varies of bones , such as dog’s , cow’s , also he went to the grave …
The bone collector had a big bag with a volume of V ,and along his trip of collecting there are a lot of bones , obviously , different bone has different value and different volume, now given the each bone’s value along his trip , can you calculate out the maximum of the total value the bone collector can get ?
 

 

Input
The first line contain a integer T , the number of cases.
Followed by T cases , each case three lines , the first line contain two integer N , V, (N <= 1000 , V <= 1000 )representing the number of bones and the volume of his bag. And the second line contain N integers representing the value of each bone. The third line contain N integers representing the volume of each bone.
 

 

Output
One integer per line representing the maximum of the total value (this number will be less than 231).
 

 

Sample Input
1 5 10 1 2 3 4 5 5 4 3 2 1
 

 

Sample Output
14
 

 

Author
Teddy
 

 

Source
 

 

Recommend
lcy
 
思路:
 
代码:

#include <iostream>
#include <cstring>
#include <cstdio>
#include <algorithm>
using namespace std;
int t,n,m;
int map[1010][1010];
int dp[1010];
int max(int x,int y)
{
return x > y ? x : y;
}
int main()
{
scanf("%d",&t);
while(t --)
{
scanf("%d%d",&n,&m);
for(int i = 1;i <= n;i ++)
scanf("%d",&map[i][0]);
for(int i = 1;i <= n;i ++)
scanf("%d",&map[i][1]);
memset(dp,0,sizeof(dp));
for(int i = 1;i <= n;i ++)
for(int j = m;j >= map[i][1];j --)
dp[j] = max(dp[j],dp[j - map[i][1]] + map[i][0]);
printf("%d\n",dp[m]);
}
}

posted on 2013-09-17 20:11  天使是一个善良的神  阅读(145)  评论(0编辑  收藏  举报

导航