HDU 1312 Red and Black

Red and Black

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 6791    Accepted Submission(s): 4309

Problem Description
There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move only on black tiles.
Write a program to count the number of black tiles which he can reach by repeating the moves described above.
 
Input
The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.
There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.
'.' - a black tile '#' - a red tile '@' - a man on a black tile(appears exactly once in a data set)
 
Output
For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).
 
Sample Input
6 9
....#.
.....#
......
......
......
......
......
#@...#
.#..#.
11 9
.#.........
.#.#######.
.#.#.....#.
.#.#.###.#.
.#.#..@#.#.
.#.#####.#.
.#.......#.
.#########.
...........
11 6
..#..#..#..
..#..#..#..
..#..#..###
..#..#..#@.
..#..#..#..
..#..#..#..
7 7
..#.#..
..#.#..
###.###
...@...
###.###
..#.#..
..#.#..
0 0
 
Sample Output
45
59
6
13
 
Source
 
Recommend
Eddy
 
思路:入门DFS,其实我更喜欢用BFS,显然用BFS能过
哎,谁让是菜鸟啊
 
代码:
#include <iostream>
#include <cstdio>
#include <stack>
#include <cstring>
using namespace std;
int w,h;
int sum;
int a,b;
struct Node
{
    int x,y;
};
int move[4][2] = {1,0,-1,0,0,1,0,-1};
int hash[22][22];
char map[22][22];
void DFS()
{
    stack < Node > s;
    Node top;top.x = a;top.y = b;
    s.push(top);
    while(!s.empty())
    {
        Node temp = s.top();s.pop();
        //printf("%d %d is %d\n",temp.x,temp.y,sum);
        for(int i = 0;i < 4;i ++)
        {
            int x = temp.x + move[i][0];int y = temp.y + move[i][1];
            if(!hash[x][y] && map[x][y] == '.' &&
            x >= 1 && x <= w && y <= h && y >= 1)
            {
                sum ++;
                hash[x][y] = 1;
                Node xin;xin.x = x;xin.y = y;
                s.push(xin);
                //hash[x][y] = 0;
            }
        }
    }
}
int main()
{
    while(scanf("%d%d",&h,&w),w != 0 && h != 0)
    {
        memset(hash,0,sizeof(hash));
        sum = 1;
        for(int i = 1;i <= w;i ++)
           for(int j = 1;j <= h;j ++)
           {
             scanf(" %c",&map[i][j]);
             if(map[i][j] == '@')
             {
                 a = i;b = j;
                 hash[i][j] = 1;
             } 
           }
        DFS();
        printf("%d\n",sum);
    }
    return 0;
}
        
  

posted on 2013-08-28 18:35  天使是一个善良的神  阅读(244)  评论(2编辑  收藏  举报

导航