hdu 1520 Anniversary party

Anniversary party
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 3590 Accepted Submission(s): 1666


Problem Description
There is going to be a party to celebrate the 80-th Anniversary of the Ural State University. The University has a hierarchical structure of employees. It means that the supervisor relation forms a tree rooted at the rector V. E. Tretyakov. In order to make the party funny for every one, the rector does not want both an employee and his or her immediate supervisor to be present. The personnel office has evaluated conviviality of each employee, so everyone has some number (rating) attached to him or her. Your task is to make a list of guests with the maximal possible sum of guests' conviviality ratings.


Input
Employees are numbered from 1 to N. A first line of input contains a number N. 1 <= N <= 6 000. Each of the subsequent N lines contains the conviviality rating of the corresponding employee. Conviviality rating is an integer number in a range from -128 to 127. After that go T lines that describe a supervisor relation tree. Each line of the tree specification has the form:
L K
It means that the K-th employee is an immediate supervisor of the L-th employee. Input is ended with the line
0 0


Output
Output should contain the maximal sum of guests' ratings.


Sample Input
7
1
1
1
1
1
1
1
1 3
2 3
6 4
7 4
4 5
3 5
0 0


Sample Output
5


Source
Ural State University Internal Contest October'2000 Students Session


Recommend
linle

//78MS    536K    838 B    C++    
/*

树形DP:
   无陷阱,做了 hdu2412 再做这题马上秒了
   dp[i][0]表示以i为根节点不选i的最优解
   dp[i][1]表示以i为根节点选i的最优解
   
   状态转移:
        
        对于根节点u及任意子节点v有: 
        dp[u][0]+=max(dp[v][0],dp[v][1]);
        dp[u][1]+=dp[v][0];
    
*/
#include<iostream>
#include<vector>
#define N 6005
using namespace std;
int dp[N][2];
int w[N];
vector<int>V[N];
int n;
void dfs(int u)
{
    dp[u][0]=0;
    dp[u][1]=w[u];
    int m=V[u].size();
    for(int i=0;i<m;i++){
        int v=V[u][i];
        dfs(v);
        dp[u][0]+=max(dp[v][0],dp[v][1]);
        dp[u][1]+=dp[v][0];
    }
}
int main(void)
{
    int a,b;
    while(scanf("%d",&n)!=EOF)
    {
        int d[N]={0};
        memset(dp,0,sizeof(dp));
        for(int i=0;i<=n;i++) V[i].clear();
        for(int i=1;i<=n;i++)
            scanf("%d",&w[i]);
        while(scanf("%d%d",&a,&b),a+b){
            V[b].push_back(a);
            d[a]++;
        }
        int id=0;
        while(d[++id]);
        dfs(id);
        printf("%d\n",max(dp[id][0],dp[id][1]));
    }
    return 0;
}

 

 

posted @ 2013-10-09 22:04  heaventouch  阅读(147)  评论(0编辑  收藏  举报