hdu 1081 To The Max

To The Max
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 6742 Accepted Submission(s): 3226


Problem Description
Given a two-dimensional array of positive and negative integers, a sub-rectangle is any contiguous sub-array of size 1 x 1 or greater located within the whole array. The sum of a rectangle is the sum of all the elements in that rectangle. In this problem the sub-rectangle with the largest sum is referred to as the maximal sub-rectangle.

As an example, the maximal sub-rectangle of the array:

0 -2 -7 0
9 2 -6 2
-4 1 -4 1
-1 8 0 -2

is in the lower left corner:

9 2
-4 1
-1 8

and has a sum of 15.


Input
The input consists of an N x N array of integers. The input begins with a single positive integer N on a line by itself, indicating the size of the square two-dimensional array. This is followed by N 2 integers separated by whitespace (spaces and newlines). These are the N 2 integers of the array, presented in row-major order. That is, all numbers in the first row, left to right, then all numbers in the second row, left to right, etc. N may be as large as 100. The numbers in the array will be in the range [-127,127].


Output
Output the sum of the maximal sub-rectangle.


Sample Input
4
0 -2 -7 0 9 2 -6 2
-4 1 -4 1 -1
8 0 -2


Sample Output
15


Source
Greater New York 2001

 

//15MS    292K    833 B    C++
//暴力枚举,枚举出所有的矩形,比较
//利用DP降低时间复杂度 
#include<stdio.h>
#include<string.h>
int g[105][105];
int dp[105];
int main(void)
{
    int n;
    while(scanf("%d",&n)!=EOF)
    {
        for(int i=1;i<=n;i++)
            for(int j=1;j<=n;j++)
                scanf("%d",&g[i][j]);
        int maxn=-127;
        for(int i=1;i<=n;i++){  //开始行 
            memset(dp,0,sizeof(dp));    
            for(int j=i;j<=n;j++){  //结束行 
                for(int k=1;k<=n;k++)  //累加 
                    dp[k]+=g[j][k];
                int temp=dp[1];
                int tmax=-127;   //便于观察= = 
                for(int k=2;k<=n;k++){  //i~j行中最优矩形 
                    if(temp<0) temp=dp[k]; 
                    else temp+=dp[k];
                    if(temp>tmax) tmax=temp;
                }
                if(tmax>maxn) maxn=tmax;
            }
        }
        printf("%d\n",maxn);
    }
    return 0;
}

 

posted @ 2013-09-29 09:11  heaventouch  阅读(134)  评论(0编辑  收藏  举报