poj 1579 Function Run Fun

Function Run Fun
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 15171   Accepted: 7849

Description

We all love recursion! Don't we?

Consider a three-parameter recursive function w(a, b, c):

if a <= 0 or b <= 0 or c <= 0, then w(a, b, c) returns:
1

if a > 20 or b > 20 or c > 20, then w(a, b, c) returns:
w(20, 20, 20)

if a < b and b < c, then w(a, b, c) returns:
w(a, b, c-1) + w(a, b-1, c-1) - w(a, b-1, c)

otherwise it returns:
w(a-1, b, c) + w(a-1, b-1, c) + w(a-1, b, c-1) - w(a-1, b-1, c-1)

This is an easy function to implement. The problem is, if implemented directly, for moderate values of a, b and c (for example, a = 15, b = 15, c = 15), the program takes hours to run because of the massive recursion.

Input

The input for your program will be a series of integer triples, one per line, until the end-of-file flag of -1 -1 -1. Using the above technique, you are to calculate w(a, b, c) efficiently and print the result.

Output

Print the value for w(a,b,c) for each triple.

Sample Input

1 1 1
2 2 2
10 4 6
50 50 50
-1 7 18
-1 -1 -1

Sample Output

w(1, 1, 1) = 2
w(2, 2, 2) = 4
w(10, 4, 6) = 523
w(50, 50, 50) = 1048576
w(-1, 7, 18) = 1

Source

 
//236K    0MS    C++    1224B
//简单的递归化DP,虽然是三维,但先处理了a,b,c后就简单了 
#include<stdio.h>
#include<string.h>
int dp[25][25][25];
int main(void)
{
    int a,b,c,a0,b0,c0;
    while(scanf("%d%d%d",&a,&b,&c)!=EOF)
    {
        if(a==-1 && b==-1 && c==-1) break;
        memset(dp,0,sizeof(dp));
        if(a<0) a0=0;
        else if(a>20) a0=20;
        else a0=a;
        if(b<0) b0=0;
        else if(b>20) b0=20; 
        else b0=b;
        if(c<0) c0=0;
        else if(c>20) c0=20;
        else c0=c;
        for(int i=0;i<=20;i++)
            for(int j=0;j<=20;j++)
                for(int k=0;k<=20;k++){
                    if(i==0 || j==0 || k==0) dp[i][j][k]=1;
                    else if(i>20 || j>20 || k>20){
                        int i0=i,j0=j,k0=k;
                        if(i>20) i0=20;
                        if(j>20) j0=20;
                        if(k>20) k0=20;
                        dp[i][j][k]=dp[i0][j0][k0];
                    }
                    else if(i<j && j<k) dp[i][j][k]=dp[i][j][k-1]+dp[i][j-1][k-1]-dp[i][j-1][k];
                    else dp[i][j][k]=dp[i-1][j][k]+dp[i-1][j-1][k]+dp[i-1][j][k-1]-dp[i-1][j-1][k-1];
                }
        printf("w(%d, %d, %d) = %d\n",a,b,c,dp[a0][b0][c0]);
    }
    return 0;
}

 

posted @ 2013-09-25 22:35  heaventouch  阅读(123)  评论(0编辑  收藏  举报