poj 1050 To the Max

To the MaxTime Limit: 1000MS Memory Limit: 10000K
Total Submissions: 37431 Accepted: 19715


Description
Given a two-dimensional array of positive and negative integers, a sub-rectangle is any contiguous sub-array of size 1*1 or greater located within the whole array. The sum of a rectangle is the sum of all the elements in that rectangle. In this problem the sub-rectangle with the largest sum is referred to as the maximal sub-rectangle.
As an example, the maximal sub-rectangle of the array:

0 -2 -7 0
9 2 -6 2
-4 1 -4 1
-1 8 0 -2
is in the lower left corner:

9 2
-4 1
-1 8
and has a sum of 15.

Input
The input consists of an N * N array of integers. The input begins with a single positive integer N on a line by itself, indicating the size of the square two-dimensional array. This is followed by N^2 integers separated by whitespace (spaces and newlines). These are the N^2 integers of the array, presented in row-major order. That is, all numbers in the first row, left to right, then all numbers in the second row, left to right, etc. N may be as large as 100. The numbers in the array will be in the range [-127,127].

Output
Output the sum of the maximal sub-rectangle.

Sample Input
4
0 -2 -7 0 9 2 -6 2
-4 1 -4 1 -1

8 0 -2

Sample Output
15

Source
Greater New York 2001

//208K    16MS    C++    862B
//二维dp,枚举全部矩形 
#include<stdio.h>
#include<string.h>
int g[105][105];
int dp[105];
int main(void)
{
    int n;
    while(scanf("%d",&n)!=EOF)
    {
        for(int i=0;i<n;i++)
            for(int j=0;j<n;j++)
                scanf("%d",&g[i][j]);
        int ans=-1<<30;
        for(int i=0;i<n;i++){  //开始行 
            memset(dp,0,sizeof(dp));
            for(int j=i;j<n;j++){   //结束行 
                for(int k=0;k<n;k++)   //每次做一次 
                    dp[k]+=g[j][k];
                int tmax=-1<<30;
                int t=dp[0];
                for(int k=1;k<n;k++){  //i到j行dp 
                    if(t<0) t=dp[k];
                    else t+=dp[k];
                    if(t>tmax) tmax=t;
                }
                if(tmax>ans) ans=tmax;
            }
        }
        printf("%d\n",ans);
    }
    return 0;
} 
                

 

posted @ 2013-09-16 21:08  heaventouch  阅读(114)  评论(0编辑  收藏  举报