BZOJ3208

3208: 花神的秒题计划Ⅰ

Time Limit: 16 Sec Memory Limit: 128 MB
Submit: 850 Solved: 562
[Submit]

[Status]

[Dicuss]

Description

背景【backboard】:

Memphis等一群蒟蒻出题中,花神凑过来秒题……

描述【discribe】:

花花山峰峦起伏,峰顶常年被雪,Memphis打算帮花花山风景区的人员开发一个滑雪项目。

我们可以把风景区看作一个nn的地图,每个点有它的初始高度,滑雪只能从高处往低处滑【严格大于】。但是由于地势经常变动【比如雪崩、滑坡】,高度经常变化;同时,政府政策规定对于每个区域都要间歇地进行保护,防止环境破坏。现在,滑雪项目的要求是给出每个nn个点的初始高度,并给出m个命令,C a b c表示坐标为a,b的点的高度改为c;S a b c d表示左上角为a,b右下角为c,d的矩形地区开始进行保护,即不能继续滑雪;B a b c d表示左上角为a b,右下角为c d的矩形地区取消保护,即可以开始滑雪;Q表示询问现在该风景区可以滑雪的最长路径为多少。对于每个Q要作一次回答。

花神一看,这不是超简单!立刻秒出了标算~

Input

第一行n,第二行开始n*n的地图,意义如上;接下来一个m,然后是m个命令,如上

Output

对于每一个Q输出单独一行的回答

Sample Input

5
1 2 3 4 5
10 9 8 7 6
11 12 13 14 15
20 19 18 17 16
21 22 23 24 25
5
C 1 1 3
Q
S 1 3 5 5
S 3 1 5 5
Q

Sample Output

24
3
样例解释:
第一个Q路线为:25->24->23->22….->3->2
第二个Q的路线为:10->9->2

HINT

100%的数据:1<=n<=700;1<=m<=1000000;其中Q、S、B操作总和<=100;
题中所有数据不超过2*10^9

题目解析:

暴力暴力暴力!

代码如下:

#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;

template <class T>T read(){
    T ans(0),flag(1);
    char c = getchar();
    for(;!isdigit(c); c = getchar())if(c == '-')flag = -1;
    for(; isdigit(c); c = getchar())ans = (ans<<1) + (ans<<3) + c - 48;
    return ans*flag;
}

const int maxn = 700 + 5;
const int dir[5] = {0,-1,0,1,0};
const int dic[5] = {0,0,-1,0,1};

int n;
int ch[maxn][maxn],f[maxn][maxn],dp[maxn][maxn];

void make_flag(int a,int b,int c,int d,int k){
    for(int i = d;i <= b; i++){
        for(int j = c;j <= a; j++){
            f[i][j] = k;
        }
    }
}

int dfs(int x,int y){
    if(dp[x][y] != 0)return dp[x][y];
    for(int i = 1;i <= 4; i++){
        int xx = dir[i] + x;
        int yy = dic[i] + y;
        if(f[xx][yy] || xx < 1 || xx > n || yy < 1 || yy > n || ch[x][y] >= ch[xx][yy])continue;
        dp[x][y] = max(dp[x][y],dfs(xx,yy) + 1);
    }
    return dp[x][y];
}

int main(){
    n = read<int>();
    for(int i = 1;i <= n; i++)
        for(int j = 1;j <= n; j++)
            ch[i][j] = read<int>();
    int T = read<int>();
    while(T--){
        char s[3];
        scanf("%s",s);
        if(s[0] == 'C'){
            int x = read<int>();
            int y = read<int>();
            ch[x][y] = read<int>();
        }
        else if(s[0] == 'S')make_flag(read<int>(),read<int>(),read<int>(),read<int>(),1);
        else if(s[0] == 'B')make_flag(read<int>(),read<int>(),read<int>(),read<int>(),0);
        else{
            memset(dp,0,sizeof(dp));
            int maxv = -0x3f3f3f;
            for(int i = 1;i <= n; i++){
                for(int j = 1;j <= n; j++){
                    if(!f[i][j]){
                        int v = dfs(i,j) + 1;
                        maxv = max(maxv,v);
                    }
                }
            }
            printf("%d\n",maxv);
        }
    }
    return 0;
}
posted @ 2017-09-08 19:20  Frade~  阅读(116)  评论(0编辑  收藏  举报