BZOJ3039
BZOJ3039: 玉蟾宫
Time Limit: 2 Sec Memory Limit: 128 MB
Description
有一天,小猫rainbow和freda来到了湘西张家界的天门山玉蟾宫,玉蟾宫宫主蓝兔盛情地款待了它们,并赐予它们一片土地。
这片土地被分成N*M个格子,每个格子里写着'R'或者'F',R代表这块土地被赐予了rainbow,F代表这块土地被赐予了freda。
现在freda要在这里卖萌。。。它要找一块矩形土地,要求这片土地都标着'F'并且面积最大。
但是rainbow和freda的OI水平都弱爆了,找不出这块土地,而蓝兔也想看freda卖萌(她显然是不会编程的……),所以它们决定,如果你找到的土地面积为S,它们每人给你S两银子。
Input
第一行两个整数N,M,表示矩形土地有N行M列。
接下来N行,每行M个用空格隔开的字符'F'或'R',描述了矩形土地。
Output
输出一个整数,表示你能得到多少银子,即(3*最大'F'矩形土地面积)的值。
Sample Input
5 6
R F F F F F
F F F F F F
R R R F F F
F F F F F F
F F F F F F
Sample Output
45
HINT
对于50%的数据,1<=N,M<=200
对于100%的数据,1<=N,M<=1000
题目解析:
这道题是一个单调栈的题目,O(NM)求一个01矩阵中的最大子矩阵,对每行求出他的1的最高高度,然后用单调栈去维护左边比他小的第一列位置,和右边比他小的第一列位置,然后就可以对每列求最大子矩阵的大小,接着chmax一下就好.
代码如下:
#include <iostream>
#include <cstdio>
#include <stack>
using namespace std;
const int maxn = 1000 + 5;
int n,m,ans;
int ch[maxn][maxn];
int l[maxn],r[maxn];
char s[3];
int main(){
scanf("%d%d",&n,&m);
for(int i = 1;i <= n; i++){
for(int j = 1;j <= m; j++){
scanf("%s",s);
ch[i][j] = (s[0] == 'F') ? 1 : 0;
}
}
for(int i = 1;i <= n; i++){
for(int j = 1;j <= m; j++){
if(ch[i][j] == 0)continue;
ch[i][j] += ch[i-1][j];
}
}
for(int i = 1;i <= n; i++){
stack<int>S1,S2;
for(int j = 1;j <= m; j++){
while(!S1.empty() && ch[i][S1.top()] >= ch[i][j])S1.pop();
l[j] = S1.empty() ? 0 : S1.top();
S1.push(j);
}
for(int j = m;j >= 1; j--){
while(!S2.empty() && ch[i][S2.top()] >= ch[i][j])S2.pop();
r[j] = S2.empty() ? m+1 : S2.top();
S2.push(j);
}
for(int j = 1;j <= m; j++){
if(ch[i][j] == 0)continue;
ans = max(ans,(r[j]-l[j]-1)*ch[i][j]);
}
}
printf("%d\n",ans*3);
return 0;
}