Problem 1004-2017 ACM/ICPC Asia Regional Shenyang Online

  • 题目来源:array array array
  • Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
    Total Submission(s): 0 Accepted Submission(s): 0
  • 题目描述和输出:
    One day, Kaitou Kiddo had stolen a priceless diamond ring. But detective Conan blocked Kiddo’s path to escape from the museum. But Kiddo didn’t want to give it back. So, Kiddo asked Conan a question. If Conan could give a right answer, Kiddo would return the ring to the museum.
    Kiddo: “I have an array A and a number k, if you can choose exactly k elements from A and erase them, then the remaining array is in non-increasing order or non-decreasing order, we say A is a magic array. Now I want you to tell me whether A is a magic array. ” Conan: “emmmmm…” Now, Conan seems to be in trouble, can you help him?
  • Input
    The first line contains an integer T indicating the total number of test cases. Each test case starts with two integers n and k in one line, then one line with n integers: A1,A2…An.
    1≤T≤20
    1≤n≤10^5
    0≤k≤n
    1≤Ai≤10^5
  • Output
    For each test case, please output “A is a magic array.” if it is a magic array. Otherwise, output “A is not a magic array.” (without quotes).
  • Sample Input
    3
    4 1
    1 4 3 7
    5 2
    4 1 3 1 2
    6 1
    1 4 3 5 4 6
  • Sample Output
    A is a magic array.
    A is a magic array.
    A is not a magic array.
  • 题目分析:
    有T个测试样例,对于每个测试样例,给定两个整数,分别是数组元素个数n和需要删除的元素个数k,如果这个数组在删除了k个元素之后,是递增或者递减的,就称这个数组是magic array,否则不是。
  • 做法:这道题是个经典的DP,换句话说就是模板题。
  • 完整代码:
#include<iostream>
#include<algorithm>
#include<cstdio>
using namespace std;
#define MAX 100005
#define INF 100000000
int dp[MAX];
int a[MAX];
int k, T, n, flag;
int main()
{
    int temp;
    cin >> T;
    while (T-- > 0)
    {
        cin >> n >> k;
        memset(a, 0, sizeof(int)*MAX);
        for (int i = 0; i < n; i++)
            cin >> a[i];
        fill(dp, dp + n, INF);
        for (int i = 0; i < n; i++)
        {
            *upper_bound(dp, dp + n, a[i]) = a[i];
        }
        temp = 0;
        while (dp[temp]<INF)
        {
            temp++;
        }
        if (temp >= n - k)
            printf("A is a magic array.\n");
        else
            printf("A is not a magic array.\n");
    }
    return 0;
}
posted @ 2017-09-10 14:30  Chasssser  阅读(150)  评论(0编辑  收藏  举报