POJ 2262 Goldbach's Conjecture

Goldbach's Conjecture
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 28052   Accepted: 10800

Description

In 1742, Christian Goldbach, a German amateur mathematician, sent a letter to Leonhard Euler in which he made the following conjecture: 
Every even number greater than 4 can be 
written as the sum of two odd prime numbers.

For example: 
8 = 3 + 5. Both 3 and 5 are odd prime numbers. 
20 = 3 + 17 = 7 + 13. 
42 = 5 + 37 = 11 + 31 = 13 + 29 = 19 + 23.

Today it is still unproven whether the conjecture is right. (Oh wait, I have the proof of course, but it is too long to write it on the margin of this page.) 
Anyway, your task is now to verify Goldbach's conjecture for all even numbers less than a million. 

Input

The input will contain one or more test cases. 
Each test case consists of one even integer n with 6 <= n < 1000000. 
Input will be terminated by a value of 0 for n.

Output

For each test case, print one line of the form n = a + b, where a and b are odd primes. Numbers and operators should be separated by exactly one blank like in the sample output below. If there is more than one pair of odd primes adding up to n, choose the pair where the difference b - a is maximized. If there is no such pair, print a line saying "Goldbach's conjecture is wrong."

Sample Input

8
20
42
0

Sample Output

8 = 3 + 5
20 = 3 + 17
42 = 5 + 37
/*
经典的哥德巴赫猜想证明,话说前不久3.18是他老人家的生日啊
那么我们就来证明一下这个结论:
Every even number greater than 4 can be 
written as the sum of two odd prime numbers.
每一个大于4的数都能拆分成两个质数相加
用筛法打表1000000的素数,再依次暴力判断
完毕
*/
#include<stdio.h>
#include<math.h>
#include<string.h>
const int MAX = 1000001; 
bool a[MAX]; // false 为素数 true 为非素数
void primelist()
{
	a[0] = a[1] = true;
	int i ,j;
	for(i = 2 ; i < MAX ; i++)
		if(a[i] == false)
			for(j = i*2 ; j < MAX ; j+=i)
				a[j] = true;
}
int main()
{
	int n;
	primelist();
	while(~scanf("%d",&n) && n!=0)
	{
		int i;
		for(i = 0 ; i <= n ; i++)
		{
			if((a[i] == false && a[n-i] == false) || a[n] == false)
			{
				printf("%d = %d + %d\n",n,i,n-i);
				break;
			}
		}
	}
	return 0;
}


posted @ 2012-03-28 16:21  Felix_F  阅读(154)  评论(0编辑  收藏  举报