POJ 3273 Monthly Expense

/*
Monthly Expense
Time Limit: 2000MS		Memory Limit: 65536K
Description

Farmer John is an astounding accounting wizard and has realized he might run out of money to run the farm. 
He has already calculated and recorded the exact amount of money (1 ≤ moneyi ≤ 10,000) that he will need 
to spend each day over the next N (1 ≤ N ≤ 100,000) days.

FJ wants to create a budget for a sequential set of exactly M (1 ≤ M ≤ N) fiscal periods called "fajomonths". 
Each of these fajomonths contains a set of 1 or more consecutive days. Every day is contained in exactly one 
fajomonth.

FJ's goal is to arrange the fajomonths so as to minimize the expenses of the fajomonth with the highest spending 
and thus determine his monthly spending limit.

Input

Line 1: Two space-separated integers: N and M 
Lines 2..N+1: Line i+1 contains the number of dollars Farmer John spends on the ith day
Output

Line 1: The smallest possible monthly limit Farmer John can afford to live with.
Sample Input

7 5
100
400
300
100
500
101
400

Sample Output

500

Hint

If Farmer John schedules the months so that the first two days are a month, the third and 
fourth are a month, and the last three are their own months, he spends at most $500 in any 
month. Any other method of scheduling gives a larger minimum monthly limit.
********************************************************
二分题...之前第一眼觉得是DP...
第二眼还是DP
然后看了Discuss才发现好像是二分...
遍历一遍以后找出最大值 和 所有值的和

  然后二分了
  以mid为中值,如果连续项的和大于mid就分割一下...
  最后判断大于小于n就行了
*/

#include<stdio.h>
#include<math.h>
int a[100010];
int m,n;
int main()
{
//	freopen("a.txt","r",stdin);
	int i;
	scanf("%d%d",&m,&n);
	int max = 0, min = -1,mid;
	for(i = 0 ; i < m ; i++)
		scanf("%d",&a[i]);
	for(i = 0 ; i < m ; i++)
	{
		max += a[i];
		if(a[i]>min)
			min = a[i];
	}
	while(min < max)//二分开始
	{
		mid = (max + min) / 2;
		int get_sum = 0;
		int get_n = 0;
		for(i = 0 ; i < m ; i++)
		{
			get_sum += a[i];
			if(get_sum > mid)
			{
				++get_n;
				get_sum = a[i];
			}
		}
		if(get_n < n) max = mid;
		else min = mid+1;
	}
	printf("%d\n",min);
	return 0;
}


posted @ 2012-03-17 00:38  Felix_F  阅读(197)  评论(0编辑  收藏  举报