1054 求平均值——20分
本题的基本要求非常简单:给定N个实数,计算它们的平均值。但复杂的是有些输入数据可能是非法的。一个“合法”的输入是[-1000,1000]区间内的实数,并且最多精确到小数点后2位。
当你计算平均值的时候,不能把那些非法的数据算在内。
输入格式:
输入第一行给出正整数N(<=100)。随后一行给出N个正整数,数字间以一个空格分隔。
输出格式:
对每个非法输入,在一行中输出“ERROR: X is not a legal number”,其中X是输入。最后在一行中输出结果:“The average of K numbers is Y”,其中K是合法输入的个数,Y是它们的平均值,精确到小数点后2位。如果平均值无法计算,则用“Undefined”替换Y。如果K为1,则输出“The average of 1 number is Y”。
输入样例1:
7
5 -3.2 aaa 9999 2.3.4 7.123 2.35
输出样例1:
ERROR: aaa is not a legal number
ERROR: 9999 is not a legal number
ERROR: 2.3.4 is not a legal number
ERROR: 7.123 is not a legal number
The average of 3 numbers is 1.38
输入样例2:
2
aaa -9999
输出样例2:
ERROR: aaa is not a legal number
ERROR: -9999 is not a legal number
The average of 0 numbers is Undefined
| 代码长度限制 | 时间限制 | 内存限制 |
| 16KB | 400ms | 64MB |
思路:
Method which came from a good partner——使用强大的正则表达式来解决问题!
代码:
#include<bits/stdtr1c++.h>
using namespace std;
int main() {
string re = "-?\\d+\\.?\\d{0,2}"; //最多一个负号,前面最少一个数字,最多一个‘.’,0-2位数字
regex reul(re);
int n, cnt = 0;
double sum = 0;
cin >> n;
for (int i = 0; i < n; i++) {
string s;
cin >> s;
double t = atof(s.c_str());
if (regex_match(s, reul) && t >= -1000 && t <= 1000) {
sum += t;
cnt++;
} else {
cout << "ERROR: " << s << " is not a legal number" << endl;
}
}
if (cnt == 0)cout << "The average of 0 numbers is Undefined";
else if (cnt == 1) printf("The average of 1 number is %.2lf", sum / cnt);
else printf("The average of %d numbers is %.2lf", cnt, sum / cnt);
return 0;
}
【推荐】国内首个AI IDE,深度理解中文开发场景,立即下载体验Trae
【推荐】编程新体验,更懂你的AI,立即体验豆包MarsCode编程助手
【推荐】抖音旗下AI助手豆包,你的智能百科全书,全免费不限次数
【推荐】轻量又高性能的 SSH 工具 IShell:AI 加持,快人一步
· TypeScript + Deepseek 打造卜卦网站:技术与玄学的结合
· Manus的开源复刻OpenManus初探
· AI 智能体引爆开源社区「GitHub 热点速览」
· C#/.NET/.NET Core技术前沿周刊 | 第 29 期(2025年3.1-3.9)
· 从HTTP原因短语缺失研究HTTP/2和HTTP/3的设计差异