C语言编程练习57:马的移动

题目描述

小明很喜欢下国际象棋,一天,他拿着国际象棋中的“马”时突然想到一个问题:
给定两个棋盘上的方格a和b,马从a跳到b最少需要多少步?
现请你编程解决这个问题。

提示:国际象棋棋盘为8格*8格,马的走子规则为,每步棋先横走或直走一格,然后再往外斜走一格。

输入

输入包含多组测试数据。每组输入由两个方格组成,每个方格包含一个小写字母(a~h),表示棋盘的列号,和一个整数(1~8),表示棋盘的行号。

输出

对于每组输入,输出一行“To get from xx to yy takes n knight moves.”。

样例输入 Copy

e2 e4
a1 b2
b2 c3
a1 h8
a1 h7
h8 a1
b1 c3
f6 f6

样例输出 Copy

To get from e2 to e4 takes 2 knight moves.
To get from a1 to b2 takes 4 knight moves.
To get from b2 to c3 takes 2 knight moves.
To get from a1 to h8 takes 6 knight moves.
To get from a1 to h7 takes 5 knight moves.
To get from h8 to a1 takes 6 knight moves.
To get from b1 to c3 takes 1 knight moves.
To get from f6 to f6 takes 0 knight moves.

思路:宽度优先搜索,每一步有8种选择。
#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <stack>
#include <queue>
#include <set>

using namespace std;
int c[8][2]={{1,2},{1,-2},{2,1},{2,-1},{-1,2},{-1,-2},{-2,-1},{-2,1}};//下一步的8种选择
int visit[9][9];//记录是否走过
int x1,y1,x2,y2;//开始和结束的坐标
int minstep;
char s1[5],s2[5];

void bfs(int a,int b,int cnt)
{
    int n,m;
    if(a==x2&&b==y2)
    {
        if(minstep>cnt)
        minstep=cnt;
        return;
    }
    if(cnt>minstep)
    {
        return;
    }
    for(int i=0;i<8;i++)
    {
        n=a+c[i][0];
        m=b+c[i][1];
        if(n>8||n<1||m<1||m>8)
        {
            continue;
        }
        if(visit[n][m]==0)
        {
            visit[n][m]=1;
            bfs(n,m,cnt+1);
            visit[n][m]=0;
        }
    }
}
int main()
{
    while(scanf("%s %s",s1,s2)!=EOF)
    {
        minstep=9999;
        x1=s1[0]-'a'+1;
        x2=s2[0]-'a'+1;
        y1=s1[1]-'0';
        y2=s2[1]-'0';
        memset(visit,0,sizeof(visit));
        visit[x1][y1]=1;
        bfs(x1,y1,0);
        printf("To get from %s to %s takes %d knight moves.\n",s1,s2,minstep);
    }
    
    return 0;
}

 

 
posted @ 2021-02-22 21:45  FantasticDoulbeFish  阅读(243)  评论(0编辑  收藏  举报