pop 3274

Gold Balanced Lineup
Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 14032   Accepted: 4045

Description

Farmer John's N cows (1 ≤ N ≤ 100,000) share many similarities. In fact, FJ has been able to narrow down the list of features shared by his cows to a list of only K different features (1 ≤ K ≤ 30). For example, cows exhibiting feature #1 might have spots, cows exhibiting feature #2 might prefer C to Pascal, and so on.

FJ has even devised a concise way to describe each cow in terms of its "feature ID", a single K-bit integer whose binary representation tells us the set of features exhibited by the cow. As an example, suppose a cow has feature ID = 13. Since 13 written in binary is 1101, this means our cow exhibits features 1, 3, and 4 (reading right to left), but not feature 2. More generally, we find a 1 in the 2^(i-1) place if a cow exhibits feature i.

Always the sensitive fellow, FJ lined up cows 1..N in a long row and noticed that certain ranges of cows are somewhat "balanced" in terms of the features the exhibit. A contiguous range of cows i..j is balanced if each of the K possible features is exhibited by the same number of cows in the range. FJ is curious as to the size of the largest balanced range of cows. See if you can determine it.

Input

Line 1: Two space-separated integers, N and K
Lines 2..N+1: Line i+1 contains a single K-bit integer specifying the features present in cow i. The least-significant bit of this integer is 1 if the cow exhibits feature #1, and the most-significant bit is 1 if the cow exhibits feature #K.

Output

Line 1: A single integer giving the size of the largest contiguous balanced group of cows.

Sample Input

7 3
7
6
7
2
1
4
2

Sample Output

4

Hint

In the range from cow #3 to cow #6 (of size 4), each feature appears in exactly 2 cows in this range

Source

 
 
就是说每个奶牛都有特征,然后有k个,用二进制表示,算出一样的最远距离。
数的哈希

#include<cstdio>

#include<cstdlib>

#include<vector>

#define MAXN 100100

#define MOD 999997

using namespace std;

int N,K,f[MAXN][31],d,b,hasha,t,ans,size;

vector<int> vec[10*MAXN];

bool isSame(int i,int j)

{

    for(int k=0;k<K;k++)

    {

        if(f[i][k]!=f[j][k])

        {

            return false;

        }

    }

    return true;

}

int main()

{

    scanf("%d%d",&N,&K);

    for(int i=1;i<=N;i++)

    {

        scanf("%d",&d);

        b=0;

        while(d)

        {

            f[i][b]=d%2;

            d/=2;

            b++;

        }

    }

    for(int i=1;i<=N;i++)

    {

        for(int j=0;j<K;j++)

        {

            f[i][j]+=f[i-1][j];

        }

    }

    for(int i=1;i<=N;i++)

    {

        for(int j=1;j<K;j++)

        {

            f[i][j]-=f[i][0];

        }

        f[i][0]=0;

    }

    vec[0].push_back(0);

    for(int i=1;i<=N;i++)

    {

        hasha=0;

        for(int j=0;j<K;j++)

        {

            hasha=(hasha*7+f[i][j])%MOD;

        }

        hasha=(hasha+MOD)%MOD;

        if(vec[hasha].size()!=0)

        {

            size=vec[hasha].size();

            for(int j=0;j<size;j++)

            {

                if(isSame(i,t=vec[hasha][j]))

                {

                    if(i-t>ans)

                    {

                        ans=i-t;

                    }

                    break;

                }

            }

        }

        vec[hasha].push_back(i);

    }

    printf("%d",ans);

    return 0;

}

posted @ 2016-04-10 17:22  大柠檬  阅读(206)  评论(1编辑  收藏  举报