11942 - Lumberjack Sequencing

Another tale of lumberjacks?. Let see ...

The lumberjacks are rude, bearded workers, while foremen tend to be bossy and simpleminded. The foremen like to harass the lumberjacks by making them line up in groups of ten, ordered by the length of their beards. The lumberjacks, being of different physical heights, vary their arrangements to confuse the foremen. Therefore, the foremen must actually measure the beards in centimeters to see if everyone is lined up in order.

Your task is to write a program to assist the foremen in determining whether or not the lumberjacks are lined up properly, either from shortest to longest beard or from longest to shortest.

Input 

The input starts with line containing a single integer N, 0 < N < 20, which is the number of groups to process. Following this are N lines, each containing ten distinct positive integers less than 100.

Output 

There is a title line, then one line per set of beard lengths. See the sample output for capitalization and punctuation.

Sample Input 

3 
13 25 39 40 55 62 68 77 88 95 
88 62 77 20 40 10 99 56 45 36 
91 78 61 59 54 49 43 33 26 18

Sample Output 

Lumberjacks: 
Ordered 
Unordered 
Ordered
解题思路:这题是判断是否输入的数有按从大到小或从小到大排列,就直接按照顺序判断,要判断两次看是从小到大还是从大到小
#include<stdio.h>
int main()
{int a[10],i,j,n,flag;
scanf("%d",&n);
printf("Lumberjacks:\n");
while(n--){
           flag=0;
           for(i=0;i<10;i++)
           scanf("%d",&a[i]);
           for(i=0,j=1;j<10;i++,j++)
           if(a[j]<=a[i]){flag++;break;}
           for(i=0,j=1;j<10;i++,j++)
           if(a[j]>a[i]){flag++;break;}
           if(flag==0||flag==1)printf("Ordered\n");
           else if(flag==2)printf("Unordered\n");
           }
return 0;
}

 

posted on 2013-02-17 11:31  喂喂还债啦  阅读(524)  评论(0编辑  收藏  举报