10783 - Odd Sum

Given a range [a, b], you are to find the summation of all the odd integers in this range. For example, the summation of all the odd integers in the range [3, 9] is

3 + 5 + 7 + 9 = 24.

Input 

There can be at multiple test cases. The first line of input gives you the number of test cases, T (

1$ \le$T$ \le$100). Then T test cases follow. Each test case consists of 2 integers a and b (

0$ \le$a$ \le$b$ \le$100) in two separate lines.

Output 

For each test case you are to print one line of output - the serial number of the test case followed by the summation of the odd integers in the range [a, b].

给你一个范围a 到b ,请你找出a 与b 之间所有奇数的和。

例如:范围[3, 9] 中所有奇数的和就是3 + 5 + 7 + 9 = 24 。

Input

输入的第一列有一个整数T (1≦T≦100),代表以下有多少组测试资料。

每组测试资料为两列,包含两个数a 与b (0≦a≦b≦100)。

Output

每组测试资料输出一列,内容为a 及b 间所有奇数的和。

Sample Input 

2
1
5
3
5

Sample Output 

Case 1: 9
Case 2: 8

解题思路:水题,先算出奇数在计算和

#include<stdio.h>
int main()
{int n,a,b,sum,i,t=1;
scanf("%d",&n);
while(n--){
           sum=0;
           scanf("%d%d",&a,&b);
           for(i=a;i<=b;i++)
           if(i%2==1)sum+=i;
           printf("Case %d: %d\n",t,sum);
           t++;
           }
return 0;
}

posted on 2013-02-06 12:35  喂喂还债啦  阅读(881)  评论(0编辑  收藏  举报