10038 - Jolly Jumpers

A sequence of n > 0 integers is called a jolly jumper if the absolute values of the difference between successive elements take on all the values 1 through n-1. For instance,

1 4 2 3

is a jolly jumper, because the absolutes differences are 3, 2, and 1 respectively. The definition implies that any sequence of a single integer is a jolly jumper. You are to write a program to determine whether or not each of a number of sequences is a jolly jumper.

Input

Each line of input contains an integer n <= 3000 followed by n integers representing the sequence.

Output

For each line of input, generate a line of output saying "Jolly" or "Not jolly".

Sample Input

4 1 4 2 3
5 1 4 2 -1 6

Sample Output

Jolly
Not jolly
解题思路:这题Jolly的条件是两个数之差在1到n-1之间且没有重复,所以先判断两数差是否在1到n-1之间,再判断差值是否重复
#include<stdio.h>
int main()
{
int n,a[3001]={0},b[3000]={0},i,j,flag;
while(scanf("%d",&n)!=EOF){flag=1;
                           for(i=0;i<n;i++)
                           scanf("%d",&a[i]);
                           for(i=0;i<n-1;i++){
                                              b[i]=a[i+1]-a[i];
                                              if(b[i]<0)
                                              b[i]=0-b[i];
                                              }
                           for(i=0;i<n-1;i++){
                                              if(flag==0)break;
                                              if(b[i]<1||b[i]>n-1){
                                                                   flag=0; 
                                                                   break;
                                                                   }
                                              else flag=1;
                           for(j=i+1;j<n-2;j++){
                                                if(b[i]==b[j]){
                                                               flag=0;
                                                               break;
                                                               }
                                                else flag=1;
                                                }
                                                }
                           if(flag==1)printf("Jolly\n");
                           else if(flag==0)printf("Not jolly\n");
                           }
return 0;
    }

 

posted on 2013-02-03 11:19  喂喂还债啦  阅读(267)  评论(0编辑  收藏  举报