10300 - Ecological Premium

German farmers are given a premium depending on the conditions at their farmyard. Imagine the following simplified regulation: you know the size of each farmer's farmyard in square meters and the number of animals living at it. We won't make a difference between different animals, although this is far from reality. Moreover you have information about the degree the farmer uses environment-friendly equipment and practices, expressed in a single integer greater than zero. The amount of money a farmer receives can be calculated from these parameters as follows. First you need the space a single animal occupies at an average. This value (in square meters) is then multiplied by the parameter that stands for the farmer's environment-friendliness, resulting in the premium a farmer is paid per animal he owns. To compute the final premium of a farmer just multiply this premium per animal with the number of animals the farmer owns.

Input

The first line of input contains a single positive integer n (<20), the number of test cases. Each test case starts with a line containing a single integer f (0<f<20), the number of farmers in the test case. This line is followed by one line per farmer containing three positive integers each: the size of the farmyard in square meters, the number of animals he owns and the integer value that expresses the farmer’s environment-friendliness. Input is terminated by end of file. No integer in the input is greater than 100000 or less than 0.

 

Output

For each test case output one line containing a single integer that holds the summed burden for Germany's budget, which will always be a whole number. Do not output any blank lines.

 德国的农夫根据他们农场的条件被发给奖金。想像以下简单的规则:你知道农场的大小也知道有多少动物住在里面。在这里我们并不去分别不同的动物有什么不同之处(虽然这跟现实有些不合)。除此之外,你还知道农夫使用环保设备及习惯的等级(称之环保等级),这等级以大于0的整数来表示。

农夫得到的奖金是根据以下的计算:首先算出每只动物平均居住的空间,然后乘以该农夫的环保等级,这样你就得到每只动物可以领多少奖金。最后再把这个值乘以所有动物的数目,就可以算出该农夫可得到奖金的数目了。

Input

输入的第一列有一个整数n(n<20),代表以下有几组测试资料。每组测试资料的第一列有1个整数f(0 < f < 20)代表在这组测试资料中有多少个农夫。接下来有f 列,每列有3个正整数,分别代表各农夫农场的面积,农场里动物的数目,该农夫的环保等级。所有输入的整数都不会比100000大,也不会比0小。

Output

对每组测试资料,请输出1个整数,代表要发给农夫的奖金的总数。

Sample Input

3
5
1 1 1
2 2 2
3 3 3
2 3 4
8 9 2
3
9 1 8
6 12 1
8 1 1
3
10 30 40
9 8 5
100 1000 70

Sample Output

38

86

7445

 解题思路:这题题目中已经给定公式了,就是每组数据的第一和第三相乘之后相加的和,同时注意对和的重新定义

#include<stdio.h>
int main()
{int n,m,a[20][3]={0},i,j,b;
scanf("%d",&n);
while(n--){
           scanf("%d",&m);
           for(b=0,i=0;i<m;i++){
                            scanf("%d %d %d",&a[i][0],&a[i][1],&a[i][2]);
                            b+=a[i][0]*a[i][2];
                            }
           printf("%d\n",b);
           }
return 0;
}

posted on 2013-01-30 20:16  喂喂还债啦  阅读(431)  评论(0编辑  收藏  举报