icpc 2017北京 J题 Pangu and Stones 区间DP

#1636 : Pangu and Stones

时间限制:1000ms
单点时限:1000ms
内存限制:256MB

描述

In Chinese mythology, Pangu is the first living being and the creator of the sky and the earth. He woke up from an egg and split the egg into two parts: the sky and the earth.

At the beginning, there was no mountain on the earth, only stones all over the land.

There were N piles of stones, numbered from 1 to N. Pangu wanted to merge all of them into one pile to build a great mountain. If the sum of stones of some piles was S, Pangu would need S seconds to pile them into one pile, and there would be S stones in the new pile.

Unfortunately, every time Pangu could only merge successive piles into one pile. And the number of piles he merged shouldn't be less than L or greater than R.

Pangu wanted to finish this as soon as possible.

Can you help him? If there was no solution, you should answer '0'.

输入

There are multiple test cases.

The first line of each case contains three integers N,L,R as above mentioned (2<=N<=100,2<=L<=R<=N).

The second line of each case contains N integers a1,a2 …aN (1<= ai  <=1000,i= 1…N ), indicating the number of stones of  pile 1, pile 2 …pile N.

The number of test cases is less than 110 and there are at most 5 test cases in which N >= 50.

输出

For each test case, you should output the minimum time(in seconds) Pangu had to take . If it was impossible for Pangu to do his job, you should output  0.

样例输入
3 2 2
1 2 3
3 2 3
1 2 3
4 3 3
1 2 3 4
样例输出
9
6
0

 

dp[i][j][k] i到j 分为k堆的最小代价  

显然 dp[i][i][1] 代价为0

然后[i,j] 可以划分 dp[i][j][k]  = min { dp[i][d][k-1] + dp[d+1][j][1] } (k > 1&&d-i+1 >= k-1,这个条件意思就是 区间i,d之间最少要有k-1个石子)  

最后合并的时候  dp[i][j][1] = min{ dp[i][d][k-1] + dp[d+1][j][1]  + sum[j] - sum[i-1] }  (l<=k<=r)

然后 需要初始化边界 dp[i][j][1] 当 i != j, dp[i][j][1] = 1

 

#include<bits/stdc++.h>
using namespace std;

const int N = 110;
const int INF = 0x3f3f3f3f;
int dp[N][N][N], s[N], sum[N];
int n,l,r;

int main () {
    //freopen("in.txt","r",stdin);
    while (~scanf("%d %d %d",&n,&l,&r)) {
        memset(dp,0x3f,sizeof(dp));
        for(int i=1;i<=n;i++)
            scanf("%d",&s[i]), sum[i]=sum[i-1]+s[i], dp[i][i][1]=0;;

        for(int len=2; len<=n; len++){
            for(int i=1; i+len-1<=n; i++) {
                int j = i+len-1;
                for(int k=2;k<=min(len,r);k++) {
                    for(int c=i+k-2; c<j ;c++) {
                        dp[i][j][k] = min(dp[i][j][k],
                                          dp[i][c][k-1]+dp[c+1][j][1]);
                    }
                }

                for(int k=l-1;k<=r-1;k++) {
                    for(int c=i+k-1; c<j ;c++) {
                        dp[i][j][1] = min(dp[i][j][1],
                                          dp[i][c][k] + dp[c+1][j][1] + sum[j]-sum[i-1]);
                    }
                }
            }
        }
        printf("%d\n",dp[1][n][1]==INF?0:dp[1][n][1]);
    }
    return 0;
}

 

posted @ 2018-08-29 15:03  Draymonder  阅读(749)  评论(0编辑  收藏  举报