hdu1003

                                                 Max Sum

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 112856    Accepted Submission(s): 26084


Problem Description
Given a sequence a[1],a[2],a[3]......a[n], your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.
 

 

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000).
 

 

Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.
 

 

Sample Input
2
5 6 -1 5 4 -7
7 0 6 -1 1 -6 7 -5
 

 

Sample Output
Case 1:
14 1 4
 
Case 2:
7 1 6

 

#include<iostream>
#include<cstring>
#include<string>
using namespace std;
int main()
{
    int n,h = 1;
    scanf("%d",&n);
    while(n--)
    {
        int m,i,j,a[100010],start,k,end,max = -10010,sum=0;
        scanf("%d",&m);
        for(i=1;i<=m;i++)
        {
            scanf("%d",&a[i]);
        }
        for(i=1,k=1;i<=m;i++)
        {
            sum += a[i];
            if(sum>max)
            {
                max = sum;
                start = k;
                end = i;
            }
            if(sum<0)
            {
                sum = 0;
                k = i+1;
            }
        }
        printf("Case %d:\n",h++);
        printf("%d %d %d\n",max,start,end);
        printf("\n");
    }
    return 0;
}

 

posted @ 2013-08-03 10:17  哥的笑百度不到  阅读(173)  评论(0编辑  收藏  举报