hdu1016

Prime Ring Problem

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 19946    Accepted Submission(s): 8935


Problem Description
A ring is compose of n circles as shown in diagram. Put natural number 1, 2, ..., n into each circle separately, and the sum of numbers in two adjacent circles should be a prime.

Note: the number of first circle should always be 1.

 

 

Input
n (0 < n < 20).
 

 

Output
The output format is shown as sample below. Each row represents a series of circle numbers in the ring beginning from 1 clockwisely and anticlockwisely. The order of numbers must satisfy the above requirements. Print solutions in lexicographical order.

You are to write a program that completes above process.

Print a blank line after each case.
 

 

Sample Input
6 8
 

 

Sample Output
Case 1:
1 4 3 2 5 6
1 6 5 2 3 4
Case 2:
1 2 3 8 5 6 7 4
1 2 5 8 3 4 7 6
1 4 7 6 5 8 3 2
1 6 7 4 3 8 5 2

 

#include<iostream>
#include<cstring>
#include<cstdio>
#include<string>
using namespace std;
int sign[21],a[21],h=0;int n;
int isprime(int n)
{
    for(int i=2;i*i<=n;i++)
    {
        if(n%i==0)
            return 0;
    }
    return 1;
}
void dfs(int x,int y)
{
    a[x] = y;
    sign[y] = 1;int i;
    if(x==n)
    {
        if(isprime(a[x]+a[1]))
        {
            printf("1");
            for(i=2;i<=n;i++)
                printf(" %d",a[i]);
            printf("\n");
        }
        return ;
    }
    for(i=1;i<=n;i++)
    {
        if(!sign[i] && isprime(a[x]+i))
        {
            dfs(x+1,i);
            sign[i] = 0;
        }
    }
    return ;
}
int main()
{
    int flag = 1;
    while(scanf("%d",&n)!=EOF)
    {
        printf("Case %d:\n",flag++);  
        memset(sign,0,sizeof(sign));
        dfs(1,1);
        printf("\n");
    }
    return 0;
}

 

posted @ 2013-07-28 10:48  哥的笑百度不到  阅读(125)  评论(0编辑  收藏  举报