hdu1042
N!
Time Limit: 10000/5000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 39265 Accepted Submission(s): 10930
Problem Description
Given an integer N(0 ≤ N ≤ 10000), your task is to calculate N!
Input
One N in one line, process to the end of file.
Output
For each N, output N! in one line.
Sample Input
1 2 3
Sample Output
1 2 6
Author
JGShining(极光炫影)
- #include<iostream>
- using namespace std;
- #define MAX 100000
- int main()
- {
- int i,j,count,n,l,temp;
- int a[MAX];
- while(scanf("%d",&n)!=EOF)
- {
- a[0]=1;
- count=1;
- for(i=1;i<=n;i++)
- {
- l=0;
- for(j=0;j<count;j++)
- {
- temp=a[j]*i+l;
- a[j]=temp%10;
- l=temp/10;
- }
- while(l)
- {
- a[count++]=l%10;
- l/=10;
- }
- }
- for(j=100000;j>0;j--)
- if(a[j])
- break;
- for(i=count-1;i>=0;i--)
- printf("%d",a[i]);
- printf("\n");
- }
- return 0;
- }