PAT Advanced 1029 Median(25)

题目描述:

Given an increasing sequence S of N integers, the median is the number at the middle position. For example, the median of S1 = { 11, 12, 13, 14 } is 12, and the median of S2 = { 9, 10, 15, 16, 17 } is 15. The median of two sequences is defined to be the median of the nondecreasing sequence which contains all the elements of both sequences. For example, the median of S1 and S2 is 13.

Given two increasing sequences of integers, you are asked to find their median.

Input Specification:

Each input file contains one test case. Each case occupies 2 lines, each gives the information of a sequence. For each sequence, the first positive integer N (≤2×105) is the size of that sequence. Then N integers follow, separated by a space. It is guaranteed that all the integers are in the range of long int.

Output Specification:

For each test case you should output the median of the two given sequences in a line.

Sample Input:

4 11 12 13 14
5 9 10 15 16 17

Sample Output:

13

算法描述:归并排序

题目大意:

给出两个序列,求两序列的中间值

#include<iostream>
#include<algorithm>
using namespace std;

int n1, n2, a[1000010];

int main()
{
    cin >> n1;
    for(int i = 0 ; i < n1 ; i ++)  scanf("%d", &a[i]);
    cin >> n2;
    for(int i = 0 ; i < n2 ; i ++)  scanf("%d", &a[n1 + i]);
    sort(a, a + n1 + n2);
    cout << a[(n1 + n2 - 1) / 2];
}
posted @   D_coding_blog  阅读(25)  评论(0编辑  收藏  举报
相关博文:
阅读排行:
· 分享一个免费、快速、无限量使用的满血 DeepSeek R1 模型,支持深度思考和联网搜索!
· 基于 Docker 搭建 FRP 内网穿透开源项目(很简单哒)
· ollama系列01:轻松3步本地部署deepseek,普通电脑可用
· 按钮权限的设计及实现
· 25岁的心里话

阅读目录(Content)

此页目录为空

点击右上角即可分享
微信分享提示