PAT Advanced 1008 Elevator(20)

题目描述:

The highest building in our city has only one elevator. A request list is made up with N positive numbers. The numbers denote at which floors the elevator will stop, in specified order. It costs 6 seconds to move the elevator up one floor, and 4 seconds to move down one floor. The elevator will stay for 5 seconds at each stop.

For a given request list, you are to compute the total time spent to fulfill the requests on the list. The elevator is on the 0th floor at the beginning and does not have to return to the ground floor when the requests are fulfilled.

Input Specification:

Each input file contains one test case. Each case contains a positive integer N, followed by N positive numbers. All the numbers in the input are less than 100.

Output Specification:

For each test case, print the total time on a single line.

Sample Input:

3 2 3 1

Sample Output:

41

算法描述:模拟

题目大意:

某栋楼只有一部电梯,先依次给出n个数,表示依次到达的楼层
上升需要6秒,下降需要4秒,停留一个楼层需要5秒
求遍历这n个楼层需要多少秒

#include<iostream>
using namespace std;

int main()
{
    int ans = 0, n, lev = 0;
    cin >> n;
    
    while(n --)
    {
        int x;
        cin >> x;
        
        if(x > lev)//上升 上升时间 + 停留时间
        {
            ans += (x - lev) * 6 + 5;
            lev = x;
        }
        else if(x < lev) // 下降
        {
            ans +=(lev - x) * 4 + 5;
            lev = x;
        }
        else // 原楼层  只需要加 停留的5秒
        {
            ans += 5;
        }
    }
    
    cout << ans << endl;
    return 0;
}
posted @   D_coding_blog  阅读(20)  评论(0编辑  收藏  举报
相关博文:
阅读排行:
· winform 绘制太阳,地球,月球 运作规律
· AI与.NET技术实操系列(五):向量存储与相似性搜索在 .NET 中的实现
· 超详细:普通电脑也行Windows部署deepseek R1训练数据并当服务器共享给他人
· 【硬核科普】Trae如何「偷看」你的代码?零基础破解AI编程运行原理
· 上周热点回顾(3.3-3.9)
历史上的今天:
2021-08-12 1012 数字分类 (20 分)
2021-08-12 sort函数用法详解
2021-08-12 1032 挖掘机技术哪家强 (20 分)
2021-08-12 1022 D进制的A+B (20 分)
2021-08-12 1016 部分A+B (15 分)
2021-08-12 1011 A+B 和 C (15 分)
2021-08-12 1002 写出这个数 (20 分)

阅读目录(Content)

此页目录为空

点击右上角即可分享
微信分享提示