PAT Advanceed 1007 Maximum Subsequence Sum(25)
题目描述:
Given a sequence of K integers { N1, N2, ..., NK }. A continuous subsequence is defined to be { Ni, Ni+1, ..., Nj } where 1≤i≤j≤K. The Maximum Subsequence is the continuous subsequence which has the largest sum of its elements. For example, given sequence { -2, 11, -4, 13, -5, -2 }, its maximum subsequence is { 11, -4, 13 } with the largest sum being 20.
Now you are supposed to find the largest sum, together with the first and the last numbers of the maximum subsequence.
Input Specification:
Each input file contains one test case. Each case occupies two lines. The first line contains a positive integer K (≤10000). The second line contains K numbers, separated by a space.
Output Specification:
For each test case, output in one line the largest sum, together with the first and the last numbers of the maximum subsequence. The numbers must be separated by one space, but there must be no extra space at the end of a line. In case that the maximum subsequence is not unique, output the one with the smallest indices i and j (as shown by the sample case). If all the K numbers are negative, then its maximum sum is defined to be 0, and you are supposed to output the first and the last numbers of the whole sequence.
Sample Input:
10
-10 1 2 3 4 -5 -23 3 7 -21
Sample Output:
10 1 4
算法描述:动态规划
#include<iostream>
#include<algorithm>
using namespace std;
const int N = 10010;
int n;
int a[N], sum[N];
int main()
{
cin >> n;
for(int i = 1 ; i <= n ; i ++)
{
scanf("%d", &a[i]);
sum[i] = sum[i - 1] + a[i];
}
int ans = -1e9, head = 0, end = n;
for(int i = 1 ; i <= n ; i ++)
{
int st = 1, t = sum[i]; //t暂存以i为结尾的连续串最大和
for(int j = 1 ; j < i ; j ++)
{
if(sum[i] - sum[j] > t)
{
t = sum[i] - sum[j];
st = j + 1;
}
}
if(t > ans)
{
head = a[st]; // head存储当前最大子串开头一个元素
end = a[i]; // end存储当前最大子串最后一个元素
ans = t;
}
}
if(ans < 0) cout << 0 << ' ' << a[1] << ' ' << a[n];
else cout << ans << ' ' << head << ' ' << end;
return 0;
}