PAT Advanted 1005 Spell It Right (20 分)

题目描述:

Given a non-negative integer N, your task is to compute the sum of all the digits of N, and output every digit of the sum in English.

Input Specification:

Each input file contains one test case. Each case occupies one line which contains an N (≤10^100).

Output Specification:

For each test case, output in one line the digits of the sum in English words. There must be one space between two consecutive words, but no extra space at the end of a line.

Sample Input:

12345

Sample Output:

one five

算法描述:字符串

题目大意:

给出一个小于等于101位的数,求该数各个位相加之后的中文读法

#include<iostream>
using namespace std;
int main() 
{
	string n;
	cin >> n;
	int sum = 0;
	for(int i = 0 ; i < n.length() ; i++)	sum += n[i] - '0';
	string str = to_string(sum);
	
	string word[10] = {"zero","one","two","three","four","five","six","seven","eight","nine"};
	
	cout << word[str[0] - '0'];
	for(int i = 1 ; i < str.length() ; i++)	cout<<' '<< word[ str[i] - '0'];
    
    return 0;
}
posted @   D_coding_blog  阅读(197)  评论(0编辑  收藏  举报
编辑推荐:
· Linux系列:如何用heaptrack跟踪.NET程序的非托管内存泄露
· 开发者必知的日志记录最佳实践
· SQL Server 2025 AI相关能力初探
· Linux系列:如何用 C#调用 C方法造成内存泄露
· AI与.NET技术实操系列(二):开始使用ML.NET
阅读排行:
· 被坑几百块钱后,我竟然真的恢复了删除的微信聊天记录!
· 没有Manus邀请码?试试免邀请码的MGX或者开源的OpenManus吧
· 【自荐】一款简洁、开源的在线白板工具 Drawnix
· 园子的第一款AI主题卫衣上架——"HELLO! HOW CAN I ASSIST YOU TODAY
· Docker 太简单,K8s 太复杂?w7panel 让容器管理更轻松!

阅读目录(Content)

此页目录为空

点击右上角即可分享
微信分享提示