PAT Advanted 1005 Spell It Right (20 分)
题目描述:
Given a non-negative integer N, your task is to compute the sum of all the digits of N, and output every digit of the sum in English.
Input Specification:
Each input file contains one test case. Each case occupies one line which contains an N (≤10^100).
Output Specification:
For each test case, output in one line the digits of the sum in English words. There must be one space between two consecutive words, but no extra space at the end of a line.
Sample Input:
12345
Sample Output:
one five
算法描述:字符串
题目大意:
给出一个小于等于101位的数,求该数各个位相加之后的中文读法
#include<iostream>
using namespace std;
int main()
{
string n;
cin >> n;
int sum = 0;
for(int i = 0 ; i < n.length() ; i++) sum += n[i] - '0';
string str = to_string(sum);
string word[10] = {"zero","one","two","three","four","five","six","seven","eight","nine"};
cout << word[str[0] - '0'];
for(int i = 1 ; i < str.length() ; i++) cout<<' '<< word[ str[i] - '0'];
return 0;
}