HDOJ5119 Happy Matt Friends(状压dp) ——2014北京现场赛H题

Problem Description
Matt has N friends. They are playing a game together.

Each of Matt’s friends has a magic number. In the game, Matt selects some (could be zero) of his friends. If the xor (exclusive-or) sum of the selected friends’magic numbers is no less than M , Matt wins.

Matt wants to know the number of ways to win.
 

Input
The first line contains only one integer T , which indicates the number of test cases.

For each test case, the first line contains two integers N, M (1 ≤ N ≤ 40, 0 ≤ M ≤ 106).

In the second line, there are N integers ki (0 ≤ ki ≤ 106), indicating the i-th friend’s magic number.
 

Output
For each test case, output a single line “Case #x: y”, where x is the case number (starting from 1) and y indicates the number of ways where Matt can win.
 

Sample Input
2 3 2 1 2 3 3 3 1 2 3
 

Sample Output
Case #1: 4 Case #2: 2
Hint
In the first sample, Matt can win by selecting: friend with number 1 and friend with number 2. The xor sum is 3. friend with number 1 and friend with number 3. The xor sum is 2. friend with number 2. The xor sum is 2. friend with number 3. The xor sum is 3. Hence, the answer is 4.

题意:给n个数,再给一个m,问有多少种方案,从这n个数中选出若干个(可以是0个),他们的异或值大于等于m。

 

d[i][j]表示前i个人异或状态为j的方案数。

则 d[i][j] = d[i-1][j] + d[i-1][j^a[i]]

 

我把0拿出来单独处理了,有一个0答案就乘一个2。

#include<iostream>
#include<algorithm>
#include<cstdio>
#include<cstring>
#include<cmath>
using namespace std;
#define rep(i,f,t) for(int i = (f), _end = (t); i <= _end; ++i)
#define debug(x) cout<<"debug  "<<x<<endl;
typedef long long int64;
int64 d[2][1<<21];

int n,m;
int a[50];
int zero;
int64 pow(int x){
    return (int64)1<<x;
}
int64 solve(){
    if(m == 0)return pow(zero+n);
    if(n == 0)return 0;
    int64 *pre = d[0], *cur = d[1];
    pre[0] = pre[a[1]] = 1;
    rep(i,2,n){
        memset(cur,0,sizeof(d[0]));
        rep(j,0,1<<20){
            cur[j] += pre[j^a[i]] + pre[j];
        }
        swap(cur,pre);
    }
    swap(cur,pre);
    int64 ans = 0;
    rep(i,m,1<<20)ans += cur[i];
    return ans<<zero;
}
int main(){
    int T;
    scanf("%d",&T);
    int cas = 0;
    while(T--){
        memset(d,0,sizeof(d));
        scanf("%d%d",&n,&m);
        zero = 0;
        for(int i = 1; i <= n; ++i){
            scanf("%d",&a[i]);
            if(a[i] == 0){
                ++zero;
                --i;--n;
            }
        }
        int64 ans = solve();
        printf("Case #%d: %I64d\n",++cas,ans);
    }
    return 0;
}



版权声明:本文为博主原创文章,未经博主允许不得转载。

posted @ 2014-12-03 01:03  DSChan  阅读(149)  评论(0编辑  收藏  举报