非常可乐 HDU - 1495

大家一定觉的运动以后喝可乐是一件很惬意的事情,但是seeyou却不这么认为。因为每次当seeyou买了可乐以后,阿牛就要求和seeyou一起分享这一瓶可乐,而且一定要喝的和seeyou一样多。但seeyou的手中只有两个杯子,它们的容量分别是N 毫升和M 毫升 可乐的体积为S (S<101)毫升 (正好装满一瓶) ,它们三个之间可以相互倒可乐 (都是没有刻度的,且 S==N+M,101>S>0,N>0,M>0) 。聪明的ACMER你们说他们能平分吗?如果能请输出倒可乐的最少的次数,如果不能输出"NO"。

Input三个整数 : S 可乐的体积 , N 和 M是两个杯子的容量,以"0 0 0"结束。Output如果能平分的话请输出最少要倒的次数,否则输出"NO"。Sample Input

7 4 3
4 1 3
0 0 0

Sample Output

NO
3
#include<iostream>
#include<queue>
#include<memory.h>
using namespace std; 
int v[5];
int sign[110][110][100]; 
struct cup
{
    int v[5];
    int step;
}temp;
void  pour(int a,int b)//讲a的水倒进b杯子里 
{
    int sum = temp.v[a]+temp.v[b];
    if(sum>=v[b])
    {
        temp.v[b]=v[b];
    }
    else
    {
        temp.v[b]=sum;
    }
    temp.v[a]=sum-temp.v[b];
    
}
void bfs()
{
    int i,j;
    queue<cup>q;
    cup cnt;
    //初始化 
    cnt.v[1]=v[1];
    cnt.v[2]=0;
    cnt.v[3]=0;
    cnt.step=0;
    q.push(cnt);
    memset(sign,0,sizeof(sign));
    sign[v[1]][0][0]=1;//s满,2小杯子空的情况 
    //bfs
    while(!q.empty())
    {
        cnt = q.front();
        q.pop();
        if(cnt.v[1]==cnt.v[3]&&cnt.v[2]==0)//大杯子一半,一个小杯子一半 
        {
            cout<<cnt.step<<endl;
            return;
        }
        for(i=1;i<4;++i)
        {
            for(int j=1;j<4;++j)
            {
                if(i!=j)//不给自己倒 
                {
                    temp=cnt;
                    pour(i,j);
                    if(!sign[temp.v[1]][temp.v[2]][temp.v[3]])//该情况未被标记 
                    {
                        temp.step++;
                        q.push(temp);//入队列 
                        sign[temp.v[1]][temp.v[2]][temp.v[3]]=1;
                    }
                }
            }
        }
    } 
    
    cout<<"NO\n";
    
}
int main()
{
    while((cin>>v[1]>>v[2]>>v[3])
            &&v[1]&&v[2]&&v[3])
    {
        if(v[1]%2)
        {
            cout<<"NO\n";
        }
        else
        {
            if(v[2]>v[3])//假设2是小杯子 3是大杯子 
            {
                int t =v[3];
                v[3]=v[2];
                v[2]=t;
            }
            bfs();
        }
    }
}

 

posted on 2018-08-17 11:05  Cute_Abacus  阅读(152)  评论(0编辑  收藏  举报

导航