UVA 10059 - Maximum Product

Given a sequence of integers S = {S1, S2, . . . , Sn}, you should determine what is the value of the
maximum positive product involving consecutive terms of S. If you cannot find a positive sequence,
you should consider 0 as the value of the maximum product.
Input
Each test case starts with 1 ≤ N ≤ 18, the number of elements in a sequence. Each element Si
is
an integer such that −10 ≤ Si ≤ 10. Next line will have N integers, representing the value of each
element in the sequence. There is a blank line after each test case. The input is terminated by end of
file (EOF).
Output
For each test case you must print the message: ‘Case #M: The maximum product is P.’, where
M is the number of the test case, starting from 1, and P is the value of the maximum product. After
each test case you must print a blank line.
Sample Input
3
2 4 -3
5
2 5 -1 2 -1
Sample Output
Case #1: The maximum product is 8.
Case #2: The maximum product is 20.

题目大意
给出一段长度为 N(N≤ 18)的整数序列,请你找出其中乘积最大且为正值的连续子序列,输出乘积值。

#include <stdio.h>
#include <string.h>
#define T 30   
//30为数组最大长度

int main()
{    
    int d,M=0;//M为组号
    while(scanf("%d",&d)!=EOF&&d<=T){
    long long pmax=0;//最大乘积
    int aray[T];//输入的数组
    memset(aray,0,sizeof(aray));

    for (int i = 0; i < d; i++)
    {
        scanf("%d",&aray[i]);

    }
    for (int i = 0; i < d; i++)
    {
        long long p=1;
        for (int j = i; j < d; j++)
        {
            p*=aray[j];
            if (p>pmax)
                pmax=p;
        }

        }

        M++;
    printf("Case #%d: The maximum product is %lld.\n\n",M,pmax);

        }

    return 0;
}
posted @ 2017-07-17 20:20  mlzc  阅读(82)  评论(0编辑  收藏  举报