HDU 1237 - 简单计算器 表达式求值

读入一个只包含 +, -, *, / 的非负整数计算表达式,计算该表达式的值。

Input

测试输入包含若干测试用例,每个测试用例占一行,每行不超过200个字符,整数和运算符之间用一个空格分隔。没有非法表达式。当一行中只有0时输入结束,相应的结果不要输出。

Output

对每个测试用例输出1行,即该表达式的值,精确到小数点后2位。

Sample Input

1 + 2
4 + 2 * 5 - 7 / 11
0

Sample Output

3.00
13.36

中缀表达式转后缀表达式然后求值 具体步骤可以参考http://www.jianshu.com/p/d7df4812a981

#include <iostream>
#include <cstdio>
#include <cstring>
#include<stack>
using namespace std;

int P(char c)
{
    if (c == '+' || c == '-') return 1;
    return 2;
}

double Ans(double x, double y, char c)
{
    if (c == '+') return x + y;
    if (c == '-') return x - y;
    if (c == '*')return x*y;
    return x / y;

}
int main() {
    int n;
    while (scanf("%d",&n)!=EOF)
    {
        char c = getchar();
        if (c=='\n'&&n == 0)break;
        stack<char> op;
        stack<double>num;
        num.push(n);
        while (true)
        {
            scanf("%c %d", &c, &n);
            char k = getchar();
            while (!op.empty()&&P(c)<=P(op.top()))
            {
                char t = op.top();
                op.pop();
                double y = num.top();
                num.pop();
                double x = num.top();
                num.pop();
                double ans = Ans(x, y, t);
                num.push(ans);
            }
            op.push(c);
            num.push(n);
            if (k == '\n')break;

        }
        while (!op.empty())
        {
            char t = op.top();
            op.pop();
            double y = num.top();
            num.pop();
            double x = num.top();
            num.pop();
            double ans = Ans(x, y, t);
            num.push(ans);
        }
        printf("%.2f\n", num.top());
    }
    return 0;
}
posted @ 2017-07-17 20:20  mlzc  阅读(175)  评论(0编辑  收藏  举报