Find Integer 解题报告(费马大定理+勾股数)

Problem Description

people in USSS love math very much, and there is a famous math problem .

give you two integers n,a,you are required to find 2 integers b,c such that an+bn=cn.

Input
one line contains one integer T;(1≤T≤1000000)

next T lines contains two integers n,a;(0≤n≤1000,000,000,3≤a≤40000)

Output
print two integers b,c if b,c exits;(1≤b,c≤1000,000,000);

else print two integers -1 -1 instead.

Sample Input
1
2 3

Sample Output
4 5

题解:
费马大定理:xn+yn=zn,n>2时没有正整数解。
勾股数:
当a是奇数时,即a=2k+1,那么b=2k2+2k,c=2k2+2k+1。
易得k=(a-1)/2,代入b=(a2-1)/2,c=(a2+1)/2。
当a是(大于4)偶数时,即a=2k,那么b=n2-1,c=n2+1。
也就是将a的一半的平方,分别-1和+1。
易得k=a/2,代入b=a2/4-1,b=a2/4+1。
所以解题代码如下:

#include<bits/stdc++.h>
using namespace std;
#define ll long long
int main()
{
    int t,n,a;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d%d",&n,&a);
        if(n==0||n>2)
            printf("-1 -1\n");
        else if(n==1)
            printf("1 %d\n",a+1);
        else
        {
            if(a%2)
                printf("%d %d\n",(a*a-1)/2,(a*a+1)/2);
            else
                printf("%d %d\n",a*a/4-1,a*a/4+1);
        }
    }
    return 0;
}

posted @ 2020-09-14 21:34  Cherish486  阅读(46)  评论(0编辑  收藏  举报