P2955 [USACO09OCT]奇数偶数Even? Odd?

题目描述

Bessie's cruel second grade teacher has assigned a list of N (1 <= N <= 100) positive integers I (1 <= I <= 10^60) for which Bessie must determine their parity (explained in second grade as 'Even... or odd?'). Bessie is overwhelmed by the size of the list and by the size of the numbers. After all, she only learned to count recently.

Write a program to read in the N integers and print 'even' on a single line for even numbers and likewise 'odd' for odd numbers.

POINTS: 25

Bessie那惨无人道的二年级老师搞了一个有 N 个正整数 I 的表叫Bessie去判断“奇偶性”(这个词语意思向二年级的学生解释,就是“这个数是单数,还是双数啊?”)。Bessie被那个表的长度深深地震惊到了,竟然跟栋栋的泛做表格一样多道题!!!毕竟她才刚刚学会数数啊。

写一个程序读入N个整数,如果是双数,那么在单立的一行内输出"even",如果是单数则类似地输出"odd".

输入输出格式

输入格式:

 

  • Line 1: A single integer: N

  • Lines 2..N+1: Line j+1 contains I_j, the j-th integer to determine even/odd

 

输出格式:

 

  • Lines 1..N: Line j contains the word 'even' or 'odd', depending on the parity of I_j

 

输入输出样例

输入样例#1:
2 
1024 
5931 
输出样例#1:
even 
odd 

说明

Two integers: 1024 and 5931

1024 is eminently divisible by 2; 5931 is not

 

看末位

复制代码
#include<iostream>
#include<cstdio>
#include<string.h>
using namespace std;
long long n,a;
char b[9999];
int main()
{
    cin>>n;
    for(int i=1;i<=n;i++)
    {
        cin>>b;
        a=b[strlen(b)-1]-'0';
        if(a%2)    printf("odd\n");
        else printf("even\n");
    }
    return 0;
} 
复制代码

 

posted @   浪矢-CL  阅读(555)  评论(0编辑  收藏  举报
编辑推荐:
· .NET Core 中如何实现缓存的预热?
· 从 HTTP 原因短语缺失研究 HTTP/2 和 HTTP/3 的设计差异
· AI与.NET技术实操系列:向量存储与相似性搜索在 .NET 中的实现
· 基于Microsoft.Extensions.AI核心库实现RAG应用
· Linux系列:如何用heaptrack跟踪.NET程序的非托管内存泄露
阅读排行:
· TypeScript + Deepseek 打造卜卦网站:技术与玄学的结合
· 阿里巴巴 QwQ-32B真的超越了 DeepSeek R-1吗?
· 如何调用 DeepSeek 的自然语言处理 API 接口并集成到在线客服系统
· 【译】Visual Studio 中新的强大生产力特性
· 2025年我用 Compose 写了一个 Todo App
点击右上角即可分享
微信分享提示