HDOJ 1501 Zipper

C串按顺序对应的字母一定要和A或B中的之母相同,否则就是NO。。。。。


Zipper

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 4837    Accepted Submission(s): 1724


Problem Description
Given three strings, you are to determine whether the third string can be formed by combining the characters in the first two strings. The first two strings can be mixed arbitrarily, but each must stay in its original order.

For example, consider forming "tcraete" from "cat" and "tree":

String A: cat
String B: tree
String C: tcraete


As you can see, we can form the third string by alternating characters from the two strings. As a second example, consider forming "catrtee" from "cat" and "tree":

String A: cat
String B: tree
String C: catrtee


Finally, notice that it is impossible to form "cttaree" from "cat" and "tree".
 

Input
The first line of input contains a single positive integer from 1 through 1000. It represents the number of data sets to follow. The processing for each data set is identical. The data sets appear on the following lines, one data set per line.

For each data set, the line of input consists of three strings, separated by a single space. All strings are composed of upper and lower case letters only. The length of the third string is always the sum of the lengths of the first two strings. The first two strings will have lengths between 1 and 200 characters, inclusive.

 

Output
For each data set, print:

Data set n: yes

if the third string can be formed from the first two, or

Data set n: no

if it cannot. Of course n should be replaced by the data set number. See the sample output below for an example.
 

Sample Input
3
cat tree tcraete
cat tree catrtee
cat tree cttaree
 

Sample Output
Data set 1: yes
Data set 2: yes
Data set 3: no
 

Source
 

Recommend
linle
 

#include <iostream>
#include <cstring>
#include <cstdio>

using namespace std;

char sa[205],sb[205],sc[410];
int lena,lenb,lenc;
bool vis[205][205];
bool OK;

void dfs(int i,int j,int k)
{
    if(k==lenc) {OK=true; return ;}
    if(vis[j])  return ;
    vis[j]=1;
    if(sa==sc[k])
        dfs(i+1,j,k+1);
    if(sb[j]==sc[k])
        dfs(i,j+1,k+1);
    if(sa!=sc[k]&&sb[j]!=sc[k])
            return ;
}

int main()
{
    int T; cin>>T;
    int cur=0;
    while(T--)
    {
        scanf("%s%s%s",sa,sb,sc);
        lena=strlen(sa);
        lenb=strlen(sb);
        lenc=strlen(sc);
        memset(vis,0,sizeof(vis));

        OK=false;
        dfs(0,0,0);
        if(OK)
            printf("Data set %d: yes\n",++cur);
        else
            printf("Data set %d: no\n",++cur);

    }

    return 0;
}

 

posted @ 2013-06-12 05:58  码代码的猿猿  阅读(136)  评论(0编辑  收藏  举报