POJ 1065 Wooden Sticks
Wooden Sticks
Time Limit: 1000MS | Memory Limit: 10000K | |
Total Submissions: 16262 | Accepted: 6748 |
Description
There is a pile of n wooden sticks. The length and weight of each stick are known in advance. The sticks are to be processed by a woodworking machine in one by one fashion. It needs some time, called setup time, for the machine to prepare processing a stick. The setup times are associated with cleaning operations and changing tools and shapes in the machine. The setup times of the woodworking machine are given as follows:
(a) The setup time for the first wooden stick is 1 minute.
(b) Right after processing a stick of length l and weight w , the machine will need no setup time for a stick of length l' and weight w' if l <= l' and w <= w'. Otherwise, it will need 1 minute for setup.
You are to find the minimum setup time to process a given pile of n wooden sticks. For example, if you have five sticks whose pairs of length and weight are ( 9 , 4 ) , ( 2 , 5 ) , ( 1 , 2 ) , ( 5 , 3 ) , and ( 4 , 1 ) , then the minimum setup time should be 2 minutes since there is a sequence of pairs ( 4 , 1 ) , ( 5 , 3 ) , ( 9 , 4 ) , ( 1 , 2 ) , ( 2 , 5 ) .
(a) The setup time for the first wooden stick is 1 minute.
(b) Right after processing a stick of length l and weight w , the machine will need no setup time for a stick of length l' and weight w' if l <= l' and w <= w'. Otherwise, it will need 1 minute for setup.
You are to find the minimum setup time to process a given pile of n wooden sticks. For example, if you have five sticks whose pairs of length and weight are ( 9 , 4 ) , ( 2 , 5 ) , ( 1 , 2 ) , ( 5 , 3 ) , and ( 4 , 1 ) , then the minimum setup time should be 2 minutes since there is a sequence of pairs ( 4 , 1 ) , ( 5 , 3 ) , ( 9 , 4 ) , ( 1 , 2 ) , ( 2 , 5 ) .
Input
The input consists of T test cases. The number of test cases (T) is given in the first line of the input file. Each test case consists of two lines: The first line has an integer n , 1 <= n <= 5000 , that represents the number of wooden sticks in the test case, and the second line contains 2n positive integers l1 , w1 , l2 , w2 ,..., ln , wn , each of magnitude at most 10000 , where li and wi are the length and weight of the i th wooden stick, respectively. The 2n integers are delimited by one or more spaces.
Output
The output should contain the minimum setup time in minutes, one per line.
Sample Input
35
4 9 5 2 2 1 3 5 1 4
3
2 2 1 1 2 2
3
1 3 2 2 3 1
Sample Output
21
3
Source
#include <iostream>
#include <cstring>
#include <cstdio>
#include <algorithm>
using namespace std;
struct Node
{
int l;
int w;
int id;
}p[5555];
bool cmp(Node x,Node y)
{
if(x.l!=y.l)
{
return x.l<y.l;
}
else
{
return x.w<y.w;
}
}
int main()
{
int T;
cin>>T;
while(T--)
{
memset(p,0,sizeof(p));
int n;
cin>>n;
for(int i=0;i<n;i++)
{
cin>>p.l>>p.w;
p.id=i;
}
sort(p,p+n,cmp);
int dp[5555];
for(int i=0;i<n;i++)
{
dp=1;
for(int j=0;j<i;j++)
{
if(p.w<p[j].w)
{
if(dp<dp[j]+1)
{
dp=dp[j]+1;
}
}
}
}
int maxn=-1;
for(int i=0;i<n;i++)
{
// cout<<p.id<<" ";
maxn=max(maxn,dp);
}
// cout<<endl;
cout<<maxn<<endl;
}
return 0;
}