POJ 1015 Jury Compromise (DP)



Jury Compromise
Time Limit: 1000MSMemory Limit: 65536K
Total Submissions: 23108Accepted: 5974Special Judge

Description

In Frobnia, a far-away country, the verdicts in court trials are determined by a jury consisting of members of the general public. Every time a trial is set to begin, a jury has to be selected, which is done as follows. First, several people are drawn randomly from the public. For each person in this pool, defence and prosecution assign a grade from 0 to 20 indicating their preference for this person. 0 means total dislike, 20 on the other hand means that this person is considered ideally suited for the jury. 
Based on the grades of the two parties, the judge selects the jury. In order to ensure a fair trial, the tendencies of the jury to favour either defence or prosecution should be as balanced as possible. The jury therefore has to be chosen in a way that is satisfactory to both parties. 
We will now make this more precise: given a pool of n potential jurors and two values di (the defence's value) and pi (the prosecution's value) for each potential juror i, you are to select a jury of m persons. If J is a subset of {1,..., n} with m elements, then D(J ) = sum(dk) k belong to J 
and P(J) = sum(pk) k belong to J are the total values of this jury for defence and prosecution. 
For an optimal jury J , the value |D(J) - P(J)| must be minimal. If there are several jurys with minimal |D(J) - P(J)|, one which maximizes D(J) + P(J) should be selected since the jury should be as ideal as possible for both parties. 
You are to write a program that implements this jury selection process and chooses an optimal jury given a set of candidates.

Input

The input file contains several jury selection rounds. Each round starts with a line containing two integers n and m. n is the number of candidates and m the number of jury members. 
These values will satisfy 1<=n<=200, 1<=m<=20 and of course m<=n. The following n lines contain the two integers pi and di for i = 1,...,n. A blank line separates each round from the next. 
The file ends with a round that has n = m = 0.

Output

For each round output a line containing the number of the jury selection round ('Jury #1', 'Jury #2', etc.). 
On the next line print the values D(J ) and P (J ) of your jury as shown below and on another line print the numbers of the m chosen candidates in ascending order. Output a blank before each individual candidate number. 
Output an empty line after each test case.

Sample Input

4 2
1 2
2 3
4 1
6 2
0 0

Sample Output

Jury #1
Best jury has value 6 for prosecution and value 4 for defence:
 2 3

Hint

If your solution is based on an inefficient algorithm, it may not execute in the allotted time.

Source


解题思路
这道题目有一定难度。碰到求最优解的问题,都可以考虑一下能否用动态规划解决。
为叙述问题方便,现将任一选择方案中,辩方总分和控方总分之差简称为“辩控差”,
辩方总分和控方总分之和称为“辩控和”。第i个候选人的辩方总分和控方总分之差记为V(i),
辩方总分和控方总分之和记为S(i)。现用f(j, k)表示,取j 个候选人,使其辩控差为k的所
有方案中,辩控和最大的那个方案(该方案称为“方案f(j, k)”)的辩控和。并且,我们还规
定,如果没法选j个人,使其辩控差为k,那么f(j, k)的值就为-1,也称方案f(j, k)不可行。
本题是要求选出m个人,那么,如果对k的所有可能的取值,求出了所有的f(m, k) (-20×m
≤ k ≤ 20×m),那么陪审团方案自然就很容易找到了。
问题的关键是建立递推关系。需要从哪些已知条件出发,才能求出f(j, k)呢?显然,方
案f(j, k)是由某个可行的方案f(j-1, x)( -20×m≤ x ≤ 20×m)演化而来的。可行方案f(j-1, x)
能演化成方案f(j, k)的必要条件是:存在某个候选人i,i 在方案f(j-1, x)中没有被选上,且
x+V(i) = k。在所有满足该必要条件的f(j-1, x)中,选出f(j-1, x) + S(i) 的值最大的那个,那
么方案f(j-1, x)再加上候选人i,就演变成了方案f(j, k)。这中间需要将一个方案都选了哪些
人都记录下来。不妨将方案f(j, k)中最后选的那个候选人的编号,记在二维数组的元素
path[j][k]中。那么方案f(j, k)的倒数第二个人选的编号,就是path[j-1][k-V[path[j][k]]。假定
最后算出了解方案的辩控差是k,那么从path
[k]出发,就能顺藤摸瓜一步步求出所有被
选中的候选人。
初始条件,只能确定f(0, 0) = 0。由此出发,一步步自底向上递推,就能求出所有的可
行方案f(m, k)( -20×m≤ k ≤ 20×m)。
实际解题的时候,会用一个二维数组f来存放f(j, k)的值。而且,由于题目中辩控差的
值k可以为负数,而程序中数租下标不能为负数,所以,在程序中不妨将辩控差的值都加上
400,以免下标为负数导致出错,即题目描述中,如果辩控差为0,则在程序中辩控差为400。



#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>

using namespace std;

int dp[30][1000],path[30][1000];
int p[202],d[202],result[30];

const int dd=500;

bool select(int a,int b,int i)
{
    while(a>0&&path[a]!=i)
    {
        b-=p[path[a]]-d[path[a]];
        a--;
    }
    if(a==0)
        return false;
    else
        return true;
}

int main()
{
    int i,j,k,a,b,n,m,ca=1;
    while(scanf("%d%d",&n,&m)!=EOF)
    {
        if(n==m&&n==0) break;
        for(i=1;i<=n;i++)
        {
            scanf("%d%d",&p,&d);
        }

        memset(dp,-1,sizeof(dp));
        memset(path,0,sizeof(path));
        dp[0][dd]=0;

        for(j=0;j<m;j++)
        {
            for(k=0;k<1000;k++)
            {
                if(dp[j][k]>=0)
                for(i=1;i<=n;i++)
                {
                    if(dp[j+1][k+p-d]<dp[j][k]+p+d)
                    {
                        a=j; b=k;
                        if(!select(a,b,i))
                        {
                            dp[j+1][k+p-d]=dp[j][k]+p+d;
                            path[j+1][k+p-d]=i;
                        }
                    }
                }
            }
        }

        for(j=0;dp
[dd+j]<0&&dp
[dd-j]<0;j++)  ;

        k=dp
[dd+j]>dp
[dd-j]?dd+j:dd-j;

        printf("Jury #%d\n",ca++);
        printf("Best jury has value %d for prosecution and value %d for defence:\n",(dp
[k]+k-dd)/2, (dp
[k]-k+dd)/2);

        for(i=1;i<=m;i++)
        {
            result=path[m-i+1][k];
            k-=p[result]-d[result];
        }

        sort(result+1,result+1+m);

        for(i=1;i<=m;i++)
        {
            printf(" %d",result);
        }
        putchar(10);
        putchar(10);
    }

    return 0;
}

posted @ 2013-07-15 23:05  码代码的猿猿  阅读(204)  评论(0编辑  收藏  举报