HDOJ 3074 Multiply game


高仿NotOnlySuccess的线段树。。。。。

Multiply game

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1217    Accepted Submission(s): 408


Problem Description
Tired of playing computer games, alpc23 is planning to play a game on numbers. Because plus and subtraction is too easy for this gay, he wants to do some multiplication in a number sequence. After playing it a few times, he has found it is also too boring. So he plan to do a more challenge job: he wants to change several numbers in this sequence and also work out the multiplication of all the number in a subsequence of the whole sequence.
  To be a friend of this gay, you have been invented by him to play this interesting game with him. Of course, you need to work out the answers faster than him to get a free lunch, He he…

 

Input
The first line is the number of case T (T<=10).
  For each test case, the first line is the length of sequence n (n<=50000), the second line has n numbers, they are the initial n numbers of the sequence a1,a2, …,an, 
Then the third line is the number of operation q (q<=50000), from the fourth line to the q+3 line are the description of the q operations. They are the one of the two forms:
0 k1 k2; you need to work out the multiplication of the subsequence from k1 to k2, inclusive. (1<=k1<=k2<=n) 
1 k p; the kth number of the sequence has been change to p. (1<=k<=n)
You can assume that all the numbers before and after the replacement are no larger than 1 million.
 

Output
For each of the first operation, you need to output the answer of multiplication in each line, because the answer can be very large, so can only output the answer after mod 1000000007.
 

Sample Input
1
6
1 2 4 5 6 3
3
0 2 5
1 3 7
0 2 5
 

Sample Output
240
420
 

Source
 

Recommend
lcy
 
 

#include <iostream>
#include <cstdio>
#include <cstring>

using namespace std;

#define lson l,m,rt<<1
#define rson m+1,r,rt<<1|1

typedef long long LL;

const int maxn=111111;
const int MOD=1000000007;

LL sum[maxn<<2];

void pushUP(int rt)
{
    sum[rt]=(sum[rt<<1]*sum[rt<<1|1])%MOD;
}

void build(int l,int r,int rt)
{
    if(l==r)
    {
        scanf("%I64d",&sum[rt]);
        return ;
    }
    int m=(l+r)>>1;
    build(lson);  build(rson);

    pushUP(rt);
}

void update(int k,int p,int l,int r,int rt)
{
    if(l==r)
    {
        sum[rt]=p;
        return ;
    }
    int m=(r+l)>>1;
    if(k<=m) update(k,p,lson);
    else update(k,p,rson);
    pushUP(rt);
}

LL query(int L,int R,int l,int r,int rt)
{
    if(L<=l&&r<=R)
    {
        return sum[rt]%MOD;
    }
    int m=(l+r)>>1;
    LL ret=1;
    if(L<=m) ret=(ret*query(L,R,lson))%MOD;
    if(R>m) ret=(ret*query(L,R,rson))%MOD;

    return ret;
}

int main()
{
    int T;
    scanf("%d",&T);
while(T--)
{
    int n;
    scanf("%d",&n);

    for(int i=0;i<=4*n;i++)
    {
        sum=1;
    }
    build(1,n,1);
    int m;
    scanf("%d",&m);
    while(m--)
    {
        int a,b,c;
        scanf("%d%d%d",&a,&b,&c);
        if(a==1)
        {
            update(b,c,1,n,1);
        }
        else
        {
            printf("%I64d\n",query(b,c,1,n,1));
        }
    }
}
    return 0;
}

posted @ 2013-08-11 18:57  码代码的猿猿  阅读(147)  评论(0编辑  收藏  举报