POJ 1840 Eqs



Eqs
Time Limit: 5000MSMemory Limit: 65536K
Total Submissions: 10828Accepted: 5261

Description

Consider equations having the following form: 
a1x13+ a2x23+ a3x33+ a4x43+ a5x53=0 
The coefficients are given integers from the interval [-50,50]. 
It is consider a solution a system (x1, x2, x3, x4, x5) that verifies the equation, xi∈[-50,50], xi != 0, any i∈{1,2,3,4,5}. 

Determine how many solutions satisfy the given equation. 

Input

The only line of input contains the 5 coefficients a1, a2, a3, a4, a5, separated by blanks.

Output

The output will contain on the first line the number of the solutions for the given equation.

Sample Input

37 29 41 43 47

Sample Output

654

Source

Romania OI 2002 


#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>

using namespace std;

int a,b,c,d,e;

int hash[2000000];

int main()
{
    scanf("%d%d%d%d%d",&a,&b,&c,&d,&e);
    int cnt=0;
    for(int i=-50;i<=50;i++)
    {
        if(i==0continue;
        for(int j=-50;j<=50;j++)
        {
            if(j==0continue;
            for(int k=-50;k<=50;k++)
            {
                if(k==0continue;
                int tmp=i*i*i*a+j*j*j*b+k*k*k*c;
                hash[cnt++]=tmp;
            }
        }
    }
    sort(hash,hash+cnt);
    int ans=0;
    for(int i=-50;i<=50;i++)
    {
        if(i==0continue;
        for(int j=-50;j<=50;j++)
        {
            if(j==0continue;
            int tmp=i*i*i*d+j*j*j*e;
            ans+=upper_bound(hash,hash+cnt,-tmp)-lower_bound(hash,hash+cnt,-tmp);
        }
    }

    printf("%d\n",ans);

    return 0;
}
* This source code was highlighted by YcdoiT. ( style: Codeblocks )
posted @ 2013-09-10 01:42  码代码的猿猿  阅读(153)  评论(0编辑  收藏  举报